1
$\begingroup$

Whenever someone answers with formatted text it looks just like how it would when they're typing it. Sometimes it works randomly, like I am able to see how it should be, but most of the time it does not. I've tried both Google Chrome and Mozilla Firefox but they have not worked. Has this ever happened to anyone before, and is there a fix for it?

$\endgroup$
  • $\begingroup$ Do you mean mathematical expressions? (Like $\exp(i\pi) = -1$.) $\endgroup$ – Lord_Farin Sep 30 '13 at 21:28
  • $\begingroup$ That is exactly what I mean. @Lord_Farin $\endgroup$ – Daniel Cook Sep 30 '13 at 21:28
  • 2
    $\begingroup$ It'd be tremendously helpful if you could post some screenshots. Do you have JavaScript enabled? What is the speed of your internet connection? $\endgroup$ – Lord_Farin Sep 30 '13 at 21:31
  • $\begingroup$ @Lord_Farin: I am not sure how to post a screenshot, is there an option for it somewhere? i don't know if it is, but it works randomly though, like I said. My internet connection's download speed is 45 mb/s. $\endgroup$ – Daniel Cook Sep 30 '13 at 21:35
  • 1
    $\begingroup$ If you edit your question, the sixth button from the left says "Image". You can paste a relevant portion of a screenshot (selected e.g. using Paint), and it'll automatically upload to imgur.com for you. $\endgroup$ – Lord_Farin Sep 30 '13 at 21:37
  • $\begingroup$ I am sorry, but I see no such buttons when I click on edit.. $\endgroup$ – Daniel Cook Sep 30 '13 at 21:44
  • $\begingroup$ I'm out of my depth, then -- sorry. $\endgroup$ – Lord_Farin Sep 30 '13 at 21:57
  • $\begingroup$ How to upload an image to a post and How do I post a screenshot on Stack Overflow?. (Although answer to the second one was posted before imgur was introduced here as the default image provider, so some steps there - namely posting to a site like imageshack - are not necessary now.) $\endgroup$ – Martin Sleziak Oct 1 '13 at 6:18
  • $\begingroup$ @extremez: by "buttons" I think one means the row of icons just above the text entry area,and just below "Your Answer" for Bold, Italics, Hyperlink, ... The sixth is indeed "Image". $\endgroup$ – DJohnM Oct 2 '13 at 0:24
2
$\begingroup$

I have also experienced similar problems with formatted math on MathSE, and I do not believe that it can be explained by a slow computer.

I am using Windows XP and Google Chrome. All updates have been installed.

The symptoms appear at random, upon starting Google Chrome and going to Math SE. If everything works, it keeps on working for the session, as I move from Math to Physics and back. If it doesn't work, it won't start working until I leave Google Chrome and come back, sometimes several times until it kicks into correct operation.

When it doesn't work, the symptoms are as follows:
At first, I see the MathJax text as typed in line: every character, including the dollar sign delimiters, in the same type face as the non-MJ text. After a few seconds, this changes. The dollar sign delimiters disappear and the remaining MJ still appears as typed, but now in a grey text colour.

Finally, after a few seconds, one of two things happens. Either the MJ text simply disappears, with the following text moving up to fill the space, as if the MJ text does not exist. There is no place to right-click to view the MJ text. Or, every instance of MJ text is replaced with the words "Math processing Error" in square brackets, italics and red text colour. If I right click on these warnings, I can see what appears to be correct MathJax text. Here's a screen shot of part of the MathSE page as I see it right now: Screen shot of Mathjax behaving badly

$\endgroup$
  • $\begingroup$ I had reported Math Processing Error before. The suggestion is to refresh/restart the browser, and hope that it works (it doesn't always). I've also found it helpful to play with comments (either show, or even add a comment), though I don't know why that works. $\endgroup$ – Calvin Lin Oct 2 '13 at 5:24
0
$\begingroup$

The reason for this is that the page is served to your browser as it was typed, and the text is then rendered as mathematical formulas via a Javascript plugin called MathJax.

On slower computers, slow connections or pages with a lot of formulas to render, the text may appear unformatted at first. This is a known issue and is intended behavior.

For example, this Physics.SE page has so much text to render that the effect should be visible on most sorts of computers and connections.

$\endgroup$
  • $\begingroup$ I'm sorry, but that OP doesn't even see the buttons while editing, and that the behaviour is intermittent (and I suspect they mean, intermittent on the same page) makes this a pre-emptive response at best, and downright unhelpful at worst. More so as OP states to have a 45 Mbps connection, while not mentioning hanging. $\endgroup$ – Lord_Farin Oct 1 '13 at 16:34
  • $\begingroup$ What buttons? MathJax is rendered automatically. I don't understand what you are saying, can you explain better what is your issue with my answer? $\endgroup$ – Sklivvz Oct 1 '13 at 16:39
  • $\begingroup$ Those mentioned in this comment. I'm convinced that there's more to this than simply "your connection or computer is too slow to render MJ properly." $\endgroup$ – Lord_Farin Oct 1 '13 at 16:49
  • $\begingroup$ It happens to me if I click on the link I provided. It could also happen if for some reason the MathJax Javascript is not available. There is no way to tell with the information provided, however the answer I provided is the simplest possible explanation. $\endgroup$ – Sklivvz Oct 1 '13 at 16:52
  • $\begingroup$ Well, that's why I think it's pre-emptive: there's no way to tell. So definitely status-bydesign is not warranted yet. Also your post speaks of fact, while you intend it is most likely that. $\endgroup$ – Lord_Farin Oct 1 '13 at 16:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .