1
$\begingroup$

I came across this question, where I saw this:

enter image description here

It looks like some sort of CSS issue, and it may have to do with the new MathJax 2.3 beta. However, I vaguely recall seeing this type of rendering glitch before -- which is why I didn't post as an answer there.

I used Windows 7 Pro SP1, x64, and Chrome 30.0.x to produce this image.

$\endgroup$
  • $\begingroup$ Thanks for the report. As a first approximation, does this issue persist when refreshing the page? FWIW, I don't see this on Chrome 31 beta/Linux. $\endgroup$ – Peter Krautzberger Oct 30 '13 at 5:53
  • $\begingroup$ Yes, it persists. Also, it doesn't occur with Opera or Firefox. $\endgroup$ – Lord_Farin Oct 30 '13 at 7:24
  • $\begingroup$ Thanks. That's very odd. I cannot reproduce this on Windows/Chrome30 either., e.g. browsershots.org/screenshots/1244f809ed35642662b2b9759bfe255d and also in a Win7 VM using Chrome 30.0.1559.101.m. I'm wondering if there are any Chrome extensions that might cause this or if you could try clearing the cache to see if it's something on SE's side (CSS etc). $\endgroup$ – Peter Krautzberger Oct 30 '13 at 15:54
  • $\begingroup$ @PeterKrautzberger I just discovered that these occurrences are generated by plain \begin{align}...\end{align} (i.e., no encompassing dollar signs, though adding them doesn't help) that have no new lines, and no aligning &. Adding the ampersand fixes the issue. Zooming also has strong effects -- the padding varies wildly and without pattern. $\endgroup$ – Lord_Farin Oct 30 '13 at 16:22
  • $\begingroup$ It therefore seems that the renderer treats the formulae as having an & at the end, which then pushes symbols out of view to the left. (Clearing cache etc. didn't work.) $\endgroup$ – Lord_Farin Oct 30 '13 at 16:23
  • $\begingroup$ Thanks, @lord_farin ! I see the behavior now when I'm zooming around. I've moved this to our bug tracker at github.com/mathjax/MathJax/issues/646 $\endgroup$ – Peter Krautzberger Oct 30 '13 at 22:27
  • $\begingroup$ @Lord_Farin, does it happen for you only when zooming? That is, is the math clipped when you first enter the page, or only when you load the page then zoom? If you zoom to a point where you get the clipping, and then reload the page, does anything change? $\endgroup$ – Davide Cervone Oct 31 '13 at 0:17
1
$\begingroup$

I'm sure that the problem is from the browser since it works perfectly in my case. (I use Firefox $25.0.1$)enter image description here


How to fix that? I would suggest that you try to change the $\text{Math Renderer}$ from SVG (?) to HTML\CSS.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .