I was pretty sure the admins had fixed things so that two backslashes worked to insert a new line in TeX, but it no longer seems to work. Or rather, it works in the preview page, but not in the final output.

Two backslashes: \begin{bmatrix}a&b\\c&d\end{bmatrix} produces $$\begin{bmatrix}a&b\\c&d\end{bmatrix}$$

Three backslashes: \begin{bmatrix}a&b\\\c&d\end{bmatrix} produces $$\begin{bmatrix}a&b\\\c&d\end{bmatrix}$$

Click "edit" to see the desired behaviour.

  • $\begingroup$ It seems that some commands no longer do the right escapes; the triple-backslash has always been necessary in align environments, so far as I can tell, and seems to be required every so often; lately, I've been seeing a disconnect again between the previewer and the renderer on \{ and \} on in-line equations as well. $\endgroup$ – Arturo Magidin Jan 24 '11 at 20:46
  • $\begingroup$ @Arturo: Here is an answer I wrote recently using double backslashes in an align environment. Strangely enough, it still works. $\endgroup$ – Rahul Jan 24 '11 at 20:52
  • $\begingroup$ Don't know; I keep using double backslash in align*s. Maybe it's the stars. $\endgroup$ – Arturo Magidin Jan 24 '11 at 20:56

This should be fixed now -- sorry about that, deployment error.

  • $\begingroup$ Has the fix been deployed, and/or will it only affect newer posts? Because the example in the question is still the same. $\endgroup$ – Rahul Jan 24 '11 at 23:13
  • $\begingroup$ @rahul you will have to do a no-op edit, adding a space, for the write to occur $\endgroup$ – Jeff Atwood Jan 24 '11 at 23:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .