9
$\begingroup$

I often get a message banner saying

"Mathematics Stack Exchange requires external JavaScript from another domain, which is blocked or failed to load".

When this happens, everything is slow, and several buttons on the page fail to work (like the button for adding comments, for example).

This happens with numerous different devices: home and work computers running Windows 7, ipad, iphone, etc. On computers, I have tried both Internet Explorer and Chrome.

In Chrome, I see a message at the bottom of the window saying "Waiting for ajax.googleapis.com".

Is there some security setting I need to tweak?

I live in China, and it's possible that the problems are being caused by the "China Great Firewall". Any other users in China see similar problems?

There is a duplicate question, from 2013, but it doesn't have an answer. I'm hoping we learned something new over the past year.

Edit
I found this, which looks helpful, but haven't tried it yet.

Another Edit
October 7th, 2014. I found a thing called Freegate, which works nicely

$\endgroup$
5
$\begingroup$

Yes, other users in China have similar experience: Use of ajax.googleapis.com not China friendly. The recent search results for "googleapis blocked in China" suggest that a number of sites are broken as a result.

Some solutions were suggested on meta.MO: JavaScript loading problem, in particular see the comment by Scott Morrison.

$\endgroup$
  • $\begingroup$ I accepted the answer, but it would be very nice if someone knowledgeable could write up a more detailed description of Scott Morrison's suggested solution. I don't really know what ssh is, and I have no idea how to "use a SOCKS proxy on port 1080". Without a "dummies guide", people like me will need to do quite a bit of work to get this to function. $\endgroup$ – bubba Aug 28 '14 at 3:27
  • $\begingroup$ @bubba Problem is, if you do not use SSH clients, this probably means you don't have a remote server to connect to (in order to tunnel out), which makes Scott Morrison's advice moot. The next best idea is a service like Hola, suggested by Tim Post. $\endgroup$ – user147263 Aug 28 '14 at 3:44
  • $\begingroup$ I'm pretty sure I do have remote systems to connect to. I typically use Windows Remote Desktop to connect to them. Is that a SSH client? I looks like there are a great many SSH clients. Does it matter which one I pick? $\endgroup$ – bubba Aug 28 '14 at 6:07
  • $\begingroup$ What features do I need to look for in this list of SSH clients? en.wikipedia.org/wiki/Comparison_of_SSH_clients $\endgroup$ – bubba Aug 28 '14 at 6:14
  • $\begingroup$ @bubba Among Windows-based clients, PuTTy is a popular option. Remote Desktop Connection is another protocol, which serves similar purposes to SSH. If the remote computer you are connecting to is outside China, then you should be able to browse normally through it. If it's within China, that does not help. $\endgroup$ – user147263 Aug 28 '14 at 12:35
0
$\begingroup$

I'm from china too, and I meet your problem too,

Now can you idea solve this problem,Now I can't comments

你好,你下面说的英文我有点不懂,怎么解决这个问题呢?我每次进这个论坛 现在无法评论了,而且每次发主题非常麻烦,非常卡的样子,有时候根本不能发帖子.谢谢

还有这个问题应该不是我一个人的问题,我用相同的搜索了下,发现最近在国内很多帖子讨论这个事情,比如我用这个复制搜索 http://www.baidu.com/s?wd=%20external%20JavaScript%20from%20another%20domain%2C%20which%20is%20blocked%20or%20failed%20to%20load&ie=utf-8&tn=baiduhome_pg&f=8&oq=a%5E2%2Bb%5E2%2Bc%5E2%3D2(a%5E3b%5E3%2Bb%5E3c%5E3%2Ba%5E3c%5E3%2B4a%5E2b%5E2c%5E2)&rsv_bp=1&rsv_enter=0&rsv_sug3=1&rsv_sug4=59&rsv_spt=1

百度显示193000个类似问题,第一页都是碰到的问题和我一样.

$\endgroup$
  • $\begingroup$ As the comments above said, this is a China firewall problem. So, you have to find a way around this firewall. Most Chinese people have found a way. It's not very difficult. An easy option is to use one of the many VPN services. $\endgroup$ – bubba Aug 31 '14 at 13:40
  • $\begingroup$ Also, for me, the "failed to load" condition doesn't happen all the time. Sometimes it goes away if I just navigate to a different page, or start a new Internet Explorer session. It happens often enough to be annoying, but not often enough to prevent me from using this site. If you are having this problem all the time, maybe there is something else going wrong, in your case. $\endgroup$ – bubba Sep 1 '14 at 6:10
  • $\begingroup$ What is this link supposed to link to? $\endgroup$ – Did Sep 1 '14 at 8:26
  • $\begingroup$ @Did -- the link takes you to a page of search results from the Baidu search engine. This is the most widely used search tool in China, since Google is not available. The entries on this page are all complaining about blocked access to the googleapis messing up sites like Stackoverflow. $\endgroup$ – bubba Sep 1 '14 at 13:05
  • $\begingroup$ bubba: Thanks for the information. $\endgroup$ – Did Sep 1 '14 at 13:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .