9
$\begingroup$

I've noticed that dollars in the “Hot Network Questions” get mistakenly loaded by MathJax, e.g.


(Feb. 23, 2017, AK) The bug is still at large, as can be seen here: enter image description here

$\endgroup$
  • $\begingroup$ Odd. The question title actually has two $$$ blocks, which may have outsmarted the block on questions with MathJax in their titles from appearing in the Hot Questions list (see MSE). (Then again, this block may only be set up for questions coming from MathJax-enabled sites, which tex.SE isn't.) The title actually appears as intended when viewed on tex.SE's Hot Question list. $\endgroup$ – user642796 Dec 3 '14 at 20:46
  • 1
    $\begingroup$ As an aside: this is interesting, as I seem to recall seeing this question a few days ago where the $$$ were not rendered. (Or, possibly, the similar question about remapping $$.) Could this have anything to do with the new update of MathJax? $\endgroup$ – apnorton Dec 4 '14 at 2:11
  • $\begingroup$ @ArthurFischer My guess is that LaTeX-containing titles are suppressed only from the sites that have MathJax enabled, but I am not going to watch the Hot List long enough to find out. $\endgroup$ – user147263 Dec 4 '14 at 2:13
  • 1
    $\begingroup$ @Behaviour that is correct; suppression only occurs for sites with MathJax enabled. A possible solution could be extending MathJax to exclude DOM elements from processing, similar to how it already allows specifying which elements to only process, via its elements option. Will look into that. $\endgroup$ – Jarrod Dixon Dec 9 '14 at 6:42
  • $\begingroup$ There is an older related bug report, which is not marked as (status-completed): Hot network questions incorrectly use MathJax. Still I am not sure whether it is a duplicate, since this one has several consecutive dollars. $\endgroup$ – Martin Sleziak Feb 23 '17 at 13:45
  • 1
    $\begingroup$ @MartinSleziak I voted to close as dupe the other one. It is about the same issue. And at least with the update this post clearly includes the other one. $\endgroup$ – quid Feb 23 '17 at 14:31
  • $\begingroup$ @JarrodDixon: Ping. $\endgroup$ – Asaf Karagila Feb 23 '17 at 17:35
  • $\begingroup$ @AsafKaragila thank you for the ping! $\endgroup$ – Jarrod Dixon Feb 23 '17 at 18:18
  • 2
    $\begingroup$ @Jarrod: No, thank you for the quick solution! $\endgroup$ – Asaf Karagila Feb 23 '17 at 18:19
6
$\begingroup$

Wow, when I last looked at this, I completely missed the "how to exclude an element from processing" in MathJax's documentation.

The tex2jax configuration has an ignoreClass option that does exactly what we need:

MathJax.Hub.Config({
    tex2jax: {
        ignoreClass: "tex2jax_ignore"
    }
});

I've added the .tex2jax_ignore class to the Hot Network Question's container element, which looks to have stopped the processing.

This fix has been built out.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .