2
$\begingroup$

The text of a question had already been edited, but the title needed editing too. I couldn't do this, except via the "improve edit" function. But then my edit was rejected as too insubstantial (even though it was necessary for the question to make sense). What is the way round this?

In response to a request, here is a link to the post concerned. (What is needed is a pair of parentheses around the argument of the limit, as is correctly done in the text of the question.)

$\endgroup$
  • $\begingroup$ Could you link to the post and the reviews please. $\endgroup$ – quid Dec 27 '14 at 13:47
  • 2
    $\begingroup$ Since when 3.5k reputation needs to suggest an edit? $\endgroup$ – Asaf Karagila Dec 27 '14 at 13:58
  • $\begingroup$ @Asaf it is tagged as "bug." $\endgroup$ – quid Dec 27 '14 at 14:00
  • $\begingroup$ @quid: Doesn't looks like a bug report. There's no link, screenshots, operating system and browser information, etc. $\endgroup$ – Asaf Karagila Dec 27 '14 at 14:02
  • $\begingroup$ @Asaf see my first comment :-) $\endgroup$ – quid Dec 27 '14 at 14:05
  • 2
    $\begingroup$ Could be that your attempted "improve" clashed with Nick's. In that case, it's just unfortunate timing. $\endgroup$ – Daniel Fischer Dec 27 '14 at 14:54
  • $\begingroup$ @DanielFischer: You may be right. I tried it again just now. This time, I did not have to go via "improve". I just edited it normally, and it worked! $\endgroup$ – John Bentin Dec 27 '14 at 15:04
  • $\begingroup$ Still it is kind of strange that this suggested edit is shown as approved by only one user. $\endgroup$ – Martin Sleziak Dec 27 '14 at 15:06
  • $\begingroup$ @MartinSleziak That was the post-owner. The owner has a binding vote on suggested edits. $\endgroup$ – Daniel Fischer Dec 27 '14 at 15:07
  • $\begingroup$ Of course, you are right @DanielFischer (I should have noticed this.) $\endgroup$ – Martin Sleziak Dec 27 '14 at 15:10
5
$\begingroup$

Let me summarize some information present in the comments with some additional commentary.

  • OP being a user having 2k+ their edits should never be subject to review, in the sense of suggested edits. Even if an edit is made via "improve edit" it normally takes effect right away and does not enter any review. Indeed, it appears that as expected no manual review happened in this case.

  • While there are some measures in place to avoid parallel edits this can not always be avoided. In case of conflicting edits the software decides if a later one is more substantive; if not it is discarded. (If this happens one sometimes gets a banner while editing saying something like: "An edit happened. Your edit can only be applied if it is more substantial.")

  • It seems this later thing is what happened. There was a "suggested edits" and subsequent other edit via "improve". The edit of OP thus likely conflicted with this edit of the post and was discarded as it was not deemed more substantial (as decided by the software).

  • The way around is to do the edit again starting from the latest (already edited) version of the post.

To sum it up: It seems the edit was only rejected due to a conflict of two edits. This is not a bug. Resubmitting the edit allows to make the correction.

$\endgroup$
  • $\begingroup$ My guess is that the clash was with the earlier suggestion, where another reviewer also chose to "Edit" the suggestion. (But of course, it's just a guess.) $\endgroup$ – Daniel Fischer Dec 27 '14 at 15:31
  • $\begingroup$ You are right. At least it was certainly not the one I mentioned, as it happened after the metapost. I took out the mention of the specific edit. $\endgroup$ – quid Dec 27 '14 at 15:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .