I recently ran into a problem. It affects mostly the Firefox of my Nexus 4, but also my Windows 8.1 tablet earlier today.

It just seems that the main MSE site does not accept the fact that I'm logged in. Regardless to re-logging in, nothing works. I can easily re-sign into gmail in private mode and then log in, and it works. But generally, logging in will just bring me back to the not logged in front page, or even worse -- it will identify me and tell me to refresh to page, to an unlogged in front page.

I tried clearing the cookies, and it worked for a whopping period of a day and a half.

The strange part is that the meta site worked just fine, but when I tried to post a question, whose content is essentially this, the phone decided that I'm not logged in on the meta site either. MathOverflow still worked as usually, but I don't think that if I tried to post stuff it would have agreed with me as well.

Did anyone else have this problem recently?

This seems to be a Google cookies issue, but I don't know, since it behaves really strangely. Maybe it's an SE issue instead.

EDIT: I tried clearing up the stackexchange cookies and the Google cookies, but it seems as if Firefox 36.0.1 insists on not writing them to the hard drive. Even when it logs in, several minutes later it will auto refresh and log me out.

EDIT 2: This problem continues. This happens on my phone (Nexus 4, Android 5) with Firefox 37 and still on my tablet (32bit Intel Atom, Windows 8.1) with Firefox 36.0.4

I found that the chat will absolutely refuse to let me log in as well from these devices. The http://chat.stackexchange.com/help page tells me that the cookies test fails. This is odd since this is essentially the only site admitting problems (although, truth be told, I don't browse a whole lot outside this website).

What I found the most striking is that the above help page mentions that "javascript cookies" need to be enabled too. But Googling the term "Javascript cookies" brought me nowhere near understanding how to make sure that those are enabled. Or what are Javascript cookies.

  • 1
    $\begingroup$ Try this. $\endgroup$
    – JRN
    Mar 11, 2015 at 1:01
  • $\begingroup$ @Joel: Nog quite applicable, since Firefox Android cannot discern between cookies. It's all or nothing. $\endgroup$
    – Asaf Karagila Mod
    Mar 11, 2015 at 5:00
  • $\begingroup$ I think your problem is similar to the one I linked to in my comment. I suspect it's due to Firefox updates. Maybe you got an update, you had your problem, you cleared the cookies, then you got another update a few days later. Just keep on clearing cookies, I suppose. $\endgroup$
    – JRN
    Mar 11, 2015 at 5:23
  • $\begingroup$ I loathe clearing cookies. What's the point of saving them, otherwise. $\endgroup$
    – Asaf Karagila Mod
    Mar 11, 2015 at 5:23
  • $\begingroup$ I randomly get signed out when I am on my iPad but I can always sign back in. I know this doesn't help but it is similar in The fact we are getting signed out when logged in. $\endgroup$
    – dustin
    Mar 11, 2015 at 16:16
  • $\begingroup$ @dustin: Can you log into the chat from your iPad? $\endgroup$
    – Asaf Karagila Mod
    Apr 2, 2015 at 15:12
  • $\begingroup$ @AsafKaragila yes no issue there. $\endgroup$
    – dustin
    Apr 2, 2015 at 15:25
  • $\begingroup$ @dustin: I see, thanks. $\endgroup$
    – Asaf Karagila Mod
    Apr 2, 2015 at 16:03
  • $\begingroup$ I now have your problem. I switched to Firefox on my linux system since it doesn't have the resource problem as chrome. I can now only log into meta sites and not the main site. Have you solved this problem? I just tried @JoelReyesNoche suggestion and it worked for me at the moment. I don't know if it will be permanent though will find out later. $\endgroup$
    – dustin
    Apr 10, 2015 at 13:35
  • $\begingroup$ @dustin: Clearing cookies would work for a few minutes; private sessions would work for a bit longer (several hours) at a time; but at some point it seemed to work for a while and stopped. So I tried clearing all cache related things (cookies, offline info, cache, logins) and it seemed to have worked for now. $\endgroup$
    – Asaf Karagila Mod
    Apr 10, 2015 at 14:03
  • $\begingroup$ I will let you know if Joel's method stops working but I think it may have done the trick. $\endgroup$
    – dustin
    Apr 10, 2015 at 14:08


You must log in to answer this question.

Browse other questions tagged .