7
$\begingroup$

MathJax not rendering

As the screenshot shows, my MathJax is not rendering and there's no word from the console (other than a bunch of probably-irrelevant CSS errors I didn't show). I restarted with add-ons disabled and this did not fix the problem.

Curiously, messing with my account's math preferences on Wikipedia appeared to do something. I didn't catch a screenshot of it, but changing to the setting "MathML with SVG or PNG fallback" caused one title to render correctly and the others to show "math processing error". This did not have an effect on the rendering of the pages, which was still LaTeX markup, and I have not been able to reproduce it since.

$\endgroup$
  • $\begingroup$ mathjax.org itself is not working currently. $\endgroup$ – JDH Mar 24 '15 at 17:38
  • $\begingroup$ Now it is again. It has been on and off all morning for me. $\endgroup$ – JDH Mar 24 '15 at 17:39
  • $\begingroup$ @JDH looks like it's okay now. $\endgroup$ – EMBLEM Mar 24 '15 at 19:00
13
$\begingroup$

Update 2015/03/30: CloudFlare reports that the issues have been resolved.

Peter from the MathJax team here. Our CDN provider has been experiencing attacks on some of its DNS servers (see also this thread on the MathJax User Group).

This attack leads to erratic DNS resolution failures. We're sorry for the inconvenience this is causing users and we'll send out an update as soon as we get any news.

$\endgroup$
  • $\begingroup$ I am also experiencing this problem. I wonder if there is some way to tell MSE to use MathML rendering if implemented by the browser. $\endgroup$ – Marko Riedel Mar 24 '15 at 21:19
  • 1
    $\begingroup$ Since SE uses MathJax to convert from TeX input to MathML that wouldn't help. $\endgroup$ – Peter Krautzberger Mar 24 '15 at 22:22
  • 1
    $\begingroup$ Hey thanks for this. I've posted a copy of this over at meta.stackexchange.com/a/251992/230261; the problem's been coming up here and there in comments, chats, and meta posts over the last few days. $\endgroup$ – Jason C Mar 24 '15 at 22:23
  • 4
    $\begingroup$ Thanks for cross posting. Sorry we missed that post last week. That would mean it's been going on a lot longer than we suspected -- sorry about that. $\endgroup$ – Peter Krautzberger Mar 24 '15 at 22:31
  • $\begingroup$ Possible work-around is to enter www.mathjax.org and cdn.mathjax.org into the etc/hosts file (Windows / Linux) and point them to 162.159.240.204. This seems to do it for me. Obviously this will stop working if they change their IP address. $\endgroup$ – Marko Riedel Mar 24 '15 at 22:34
  • $\begingroup$ Experienced the same problems for a couple of days, for my local PC implementations as well. Which is explained by the fact that the whole MathJax site and so any linking to it is unavailable at the moment of this writing. $\endgroup$ – Han de Bruijn Mar 25 '15 at 14:44
  • $\begingroup$ updated the post -- the problem should be resolved now. $\endgroup$ – Peter Krautzberger Mar 30 '15 at 9:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .