I am having a similar problem as in this previous post. Just recently, ALL MathJax formulas started appearing twice in my browser. However, unlike in the linked post, it happens every time I load MathJax (rather than being occasional and not reproducible) and it cannot be fixed by refreshing.

What is interesting is that it loads properly at first, but then after several seconds invariably reverts to two copies of every formula -- one correct, and one spaced some arbitrary amount to the right and down from the correct location. The amount is not the same every time it happens. Examples:

enter image description here

enter image description here

Any idea what's wrong? I can still read things on the site of course, but it's more difficult.

In case it matters, I'm using:

  • Chrome 50.0.2661.94 (Official Build) (64-bit)
  • Ubuntu Linux
  • JavaScript V8
  • $\begingroup$ It is not a solution, just a workaround until the things are fixed. But have you tried refresh or hard refresh as recommended in the comments to the other question? $\endgroup$ Commented May 9, 2016 at 6:46
  • 1
    $\begingroup$ @MartinSleziak Yes, as I mentioned in my post refreshing doesn't work (ctrl-R). I now tried ctrl-F5 as well, which clears the cache I think but that didn't do anything either. It does change the amount right/down that the copy formula appears, which still seems random to me. $\endgroup$ Commented May 9, 2016 at 6:51
  • $\begingroup$ I personally have not seen something like this. So it is difficult to give some advice. (Since I cannot test it.) However I have seen this occasionally in the sidebar. What I have noticed in those cases, that the problem usually appeared when I used a link to a comment. If I used a link directly to the question, it work fine. $\endgroup$ Commented May 9, 2016 at 7:13
  • $\begingroup$ One natural question is: Do you also have some other browsers you could try? Does it work the same in them? $\endgroup$ Commented May 9, 2016 at 7:14
  • $\begingroup$ @MartinSleziak Yeah I should have checked the obvious things like that. Found the culprit and posted an answer. $\endgroup$ Commented May 9, 2016 at 7:33
  • $\begingroup$ I have added (google-chrome) tag, since from your answer it seems that this particular instance of the problem was browser dependent. (Or extension-dependent, but I do not think we have a tag for that.) Of course, if you think that the tag does not fit, feel free to remove it. $\endgroup$ Commented May 9, 2016 at 7:37

1 Answer 1


False alarm: caused by chrome extension

I should have checked before what happens when I turn off all my extensions (or log into chrome from a different user). It turns out the culprit was an obscure Chrome extension I had installed called "Emoji Input by EmojiStuff.com" that was supposed to allow viewing certain emoji characters that I couldn't otherwise view. (This extension.)

Anyway I've disabled the extension now, and everything is working properly. Sorry for what turned out to be a not very useful question, very specific rather than of general interest.

I do wonder what in the world that extension was trying to do that ruined MathJax behavior.

  • 2
    $\begingroup$ I had a similar problem with the extension "TeX All the Things". $\endgroup$
    – tsbertalan
    Commented Nov 23, 2018 at 19:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .