6
$\begingroup$

Until recently I was quite pleased with the responsiveness of the MSE editor field: preview (and thus typing) seemed to be proportional to the number of formulae input, but something happened and now even short answers take a lot of CPU (I can hear the fan turning quite noisily), and the entire experience is quite annoying: the letters that I type get collected in a queue from which I see them being output o-...-n-...-e-...-b-...-y-...-o-...-n-...-e. Have the MathJax gods changed anything in the code, recently? Is it possible to disable the preview (but having the possibility to re-enable it at will during writing in order to check the rendering from time to time)?

The machine I am using is the same, and the browser is always the latest version of Firefox with just uBlock (as extension), and Flash, Java, VLC and OpenH264 (as plug-ins), so it can't be from me.

(I am aware that similar questions have been asked, but they cannot be considered duplicates since they may always point to new bugs in the SE software).


A clarification: when I say "a MathJax bug", I believe that in fact I should say "a bug in the MathJax renderer". The one that causes my problem is HTML-CSS. I am going to switch to Common-HTML and see if the problem persists. I must also add that this behaviour is random - sometimes preview is perfectly usable.

$\endgroup$
  • 1
    $\begingroup$ I haven't seen anything different, whether on chrome or on firefox. Are you sure your machine isn't to blame? Is some process hogging the CPU by any chance? Is another one of Firefox's tabs rendering something complicated, is your RAM full and you're swapping...? $\endgroup$ – Najib Idrissi Jul 17 '16 at 17:57
  • $\begingroup$ @NajibIdrissi: Absolutely not (that's why I have included that paragraph). Suffice to say that I am also a Linux user since 1997, so I have at least a basic understanding of what my machine does and how to diagnose things, so I would rule that possibility out. $\endgroup$ – Alex M. Jul 17 '16 at 17:59
  • 7
    $\begingroup$ Nothing has changed with MathJax recently, nor (to my knowledge) in the code used to connect MathJax and the preview editor. Have you actually verified that Firefox is the process that is taking all the CPU, while you have only one tab open? Has Firefox updated itself recently (it is possible that a new version of Firefox has new behavior that is problematic for the editor). In my experience "it can't be me" are famous last words. $\endgroup$ – Davide Cervone Jul 17 '16 at 22:05
  • $\begingroup$ Flash is the root of all evil. It's also mostly unnecessary nowadays when most sites switched to HTML5. Try removing it entirely to see what happens. $\endgroup$ – Asaf Karagila Jul 18 '16 at 23:47
  • $\begingroup$ @AsafKaragila: Flash is set to "Ask to Activate", so it cannot be from this. And the above "suggestions" tend to be a little irritating: I am happy, though, that I haven't been advised to scan my machine for malware, or even to check whether it is turned on. Seriously, I consider myself to be above that level. $\endgroup$ – Alex M. Jul 19 '16 at 5:46
  • $\begingroup$ Alex, I've only been a serious Linux user since 2006, but the flashplugin is buggy as hell. Even at semi disabled it still used to kill my X from time to time. One option I can suggest is to try the site with a different browser. Perhaps something lightweight, or at least something you don't have a lot of add-ons installed (for me that would be Epiphany), and if you have a second Gecko browser, even better. See if the site slugs down when changing browsers and engines. $\endgroup$ – Asaf Karagila Jul 19 '16 at 5:58
  • $\begingroup$ I got this lagging before when I created too many macros. Now I always finish the macro before enclosing it in $$, and remove the $$ whenever I need to edit it. $\endgroup$ – user21820 Jul 26 '16 at 11:40

You must log in to answer this question.

Browse other questions tagged .