1
$\begingroup$

The following happens to me using Firefox 5.0 on OS X 10.6.7, but also on Firefox 4.0.3 (with all plugins disabled and emptied cache, restarted etc). It doesn't happen with Safari 5.0.5, though.


Until recently, right-clicking on a formula and selecting "show source" yielded a pop-up window showing the LaTeX-source. For instance, the very simple formula

$$\max{\{a,b\}} = \frac{a+b}{2} + \frac{|a-b|}{2}$$

appearing in this answer was created using

\max{\{a,b\}} = \frac{a+b}{2} + \frac{|a-b|}{2}

Right-clicking on the formula (on the main site!) and selecting "show source" now yields the following human-unreadable garbage (excerpt of about a screen full of similar lines)

<math xmlns="http://www.w3.org/1998/Math/MathML" display="block">
  <mo movablelimits="true">max</mo>
  <mrow>
    <mo fence="false" stretchy="false">{</mo>
    <mi>a</mi>
    <mo>,</mo>
    <mi>b</mi>
    <mo fence="false" stretchy="false">}</mo>
  </mrow>
...

On the meta site, we still have the desired result. Could this please be re-installed on the main site, because this feature is very useful for referring LaTeX-unsavvy users to, while the new result is of no use, really.

$\endgroup$
  • 1
    $\begingroup$ I don't see any problems - I get the right popup when I click "show source" (on the main site!). $\endgroup$ – Hendrik Vogt Jun 24 '11 at 8:47
  • 1
    $\begingroup$ Works fine for me (Win7, Chrome 13) $\endgroup$ – Grigory M Jun 24 '11 at 8:47
  • $\begingroup$ By the way: if it matters, I currently use FF 5 on OS X 10.6.7, but I don't think this is browser and OS specific. $\endgroup$ – t.b. Jun 24 '11 at 8:48
  • $\begingroup$ @Theo: It might play a role that FF 5 is not officially released and hence not a supported browser for the site. $\endgroup$ – Hendrik Vogt Jun 24 '11 at 8:52
  • $\begingroup$ @Hendrik: I don't know what it means for FF 5 to be "officially released". My FF 4 updated itself to 5 and when I go to mozilla.org, they automatically provide me with FF 5 when I'm trying to download the software. $\endgroup$ – t.b. Jun 24 '11 at 9:01
  • $\begingroup$ I just downloaded FF 5, and it works fine for me. $\endgroup$ – Jonas Meyer Jun 24 '11 at 9:07
  • $\begingroup$ @Theo: I'm really sorry, I'm not up to date. I only knew that FF 4 was released not too long ago, and this was years after FF 3. It came as a complete surprise to me that FF 5 has been released already! $\endgroup$ – Hendrik Vogt Jun 24 '11 at 9:12
  • $\begingroup$ Thanks @Jonas. I tried several things, but it still doesn't work as I think it should with FF 5. On the other hand, this feature isn't really important for me, and if no-one else experiences this problem, I don't care much. What is the proper procedure? Should I leave that question or should I delete it? $\endgroup$ – t.b. Jun 24 '11 at 9:12
  • $\begingroup$ @Theo Why, leave it, maybe someone else has the same problem $\endgroup$ – Grigory M Jun 24 '11 at 9:14
  • $\begingroup$ @Hendrik: I was surprised, too. IIRC FF4 was released in March and FF5 a few days ago, maybe they just increased the wrong counter as I don't experience much difference :) and the update was described as "stability fixes". $\endgroup$ – t.b. Jun 24 '11 at 9:14
  • $\begingroup$ I would leave it. If someone figures out what's causing it, it might help other users. At worst, it can be tagged [status-norepro] and forgotten. $\endgroup$ – Jonas Meyer Jun 24 '11 at 9:14
  • $\begingroup$ Okay, very well then. I leave it. $\endgroup$ – t.b. Jun 24 '11 at 9:17
  • $\begingroup$ @Hendrik and Theo: Mozilla decided to change their versioning model after Firefox 4. This is supposed to "induce quicker turn-around in implementing features" (paraphrasing the official statement), but I think it is just copy-catting the rapid Major version number bumps of Google Chrome. See here. $\endgroup$ – Willie Wong Jun 24 '11 at 12:46
  • $\begingroup$ @Theo: The menu in FF5 on OSX 10.6.7 works fine for me. Make sure to use "Show Source" not "View Selection Source". $\endgroup$ – Jack Schmidt Jun 24 '11 at 14:54
  • $\begingroup$ @Jack: Thanks a lot for that, so it must be something on my machine, I'll try to figure out what exactly myself. What you're suggesting is not the problem. $\endgroup$ – t.b. Jun 24 '11 at 15:06
2
$\begingroup$

Can't reproduce, in Firefox 5 on Windows 7:

enter image description here

$\endgroup$
  • $\begingroup$ Thanks a lot for looking into it. $\endgroup$ – t.b. Jun 24 '11 at 9:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .