2
$\begingroup$

In a comment to an answer I wrote, I noticed the following problem with the size of \right\rceil: $$ n=\left\lceil e^{W\left(\frac{\log \left(\frac{n!}{\sqrt{2\pi}}\right)}{e}\right)+1}-\frac{1}{2}\right\rceil $$ changing the \rceil to ] gives the proper sizing: $$ n=\left\lceil e^{W\left(\frac{\log \left(\frac{n!}{\sqrt{2\pi}}\right)}{e}\right)+1}-\frac{1}{2}\right] $$ Note: I just noticed that this does not show on my iPhone, so I am posting a picture of what I see:

enter image description here

I am running Mac OS X 10.11.5 and using Firefox 50.1.0.

As MartinR comments, if I change the renderer from "HTML-CSS" to "Common HTML", things render okay.

$\endgroup$
  • $\begingroup$ Strange. My laptop (Windows 7, Firefox ?) shows it correctly. $\endgroup$ – Jyrki Lahtonen Jan 2 '17 at 7:36
  • 1
    $\begingroup$ Can reproduce with Safari on macOS 10.12.2. Setting the "Math Renderer" to "Common HTML" instead of "HTML-CSS" makes it display correctly. $\endgroup$ – Martin R Jan 2 '17 at 7:44
  • 1
    $\begingroup$ @MartinR: Indeed, setting the renderer to "Common HTML" fixes it for me, too. $\endgroup$ – robjohn Jan 2 '17 at 8:18
4
$\begingroup$

It turns out that there is a typo in the data file for local STIX fonts for the HTML-CSS output. This typo causes \rceil not to be able to stretch past the size of the largest single-glyph version in the font (i.e., the data for the multi-character stretchy version is effectively missing). The easiest solution, as already pointed out, is to switch the renderer, since this only affects the HTML-CSS output (and only with local STIX fonts). Alternative solutions would include switching to one of the other fonts available to MathJax (if you want to do that, I can tell you how), or installing the MathJax fonts locally, since they are used in preference to STIX, when available.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .