18
$\begingroup$

I happened to notice that this question which I had previously answered has been deleted. That's perfectly fine by me, and I don't mean to question the deletion itself in any way.

What I find odd is that my answer which got deleted alongside (of course) is now marked "deleted by owner" and has a +1 "undelete" count alleging that I "voted to undelete". Thing is that I have not taken either action: I did not delete my own answer, and I did not vote to undelete it. FWIW the other two answers to the same question are simply marked "deleted" and have no "undelete" votes.

This does not appear to be common behavior, as far as I can tell by looking at similar situations. Can't help but wonder what's different in this particular case.

$\endgroup$
  • 4
    $\begingroup$ Incidentally, the deletion of the question was caused by the deletion of the account of the question's author. In such cases, all posts with negative score are deleted. $\endgroup$ – Daniel Fischer Jan 9 '17 at 23:26
19
$\begingroup$

You did delete your answer 15 seconds after you posted it, and undeleted it about two and a half minutes thereafter.

For some unfathomable reason, the software shows "deleted by owner" and the presence of an undelete vote when the question is later deleted and the author of the answer has deleted and undeleted their answer before the deletion of the question.

I guess that behaviour qualifies as a bug, but it's not a high-priority bug, since it doesn't occur too often, and it's only visible to few users.

$\endgroup$
  • 3
    $\begingroup$ Thank you, makes sense now. I was pretty sure I hadn't deleted my answer "one hour ago" but didn't remember the history all the way back to last November. I agree with the rest, and if this were my software bug I would probably not consider it too high-pri either ;-) $\endgroup$ – dxiv Jan 9 '17 at 23:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .