Since switching to OS/X Lion in two computers, math fonts on MSE look all wrong. Has anyone else noticed that? Am I mistaken in associating the change with the OS switch?

Here's a quick formula:

$\int_{-\infty}^{\infty}e^{-x^2}dx = \sqrt{\pi}$

and here's what it looks like:

screenshot of rendered formula

  • $\begingroup$ Looks screwy. Did you try looking at the examples on the MathJax home page to see if you see the same rendering problem there? $\endgroup$ – J. M. is a poor mathematician Jul 27 '11 at 6:46
  • 1
    $\begingroup$ Did you try right-clicking on the formula and switch the math-renderer under "Settings -> Math Renderer -> ..."? Also you could check if you have the stixfonts installed properly (I'm not 100% sure that you actually need them.) $\endgroup$ – t.b. Jul 27 '11 at 8:30
  • $\begingroup$ @Theo, I think OS/X is a Macintosh operating system, and typically Macs don't have "right-clicking". $\endgroup$ – Gerry Myerson Jul 27 '11 at 12:56
  • 1
    $\begingroup$ @Gerry: Yes, you're certainly right. However, I thought that being a person working at facebook, Alon is certainly aware that "right-clicking" can be achieved on a Mac in a number of ways, e.g. ctrl+click or whatever means he has set up to perform a secondary click (on the trackpad, magic mouse...) $\endgroup$ – t.b. Jul 27 '11 at 13:26
  • $\begingroup$ Ha! I have just encountered the same problem. On OS X 10.6 it is fine and on OS X 10.7 it looks like this. $\endgroup$ – Jonas Teuwen Jul 27 '11 at 13:56
  • $\begingroup$ I have tried to disable the STIX fonts in Font Book, but it doesn't seem to help. $\endgroup$ – Jonas Teuwen Jul 27 '11 at 14:06
  • $\begingroup$ @Jonas: have you tried ctrl-clicking on the formula and changing the renderer? $\endgroup$ – t.b. Jul 27 '11 at 14:10
  • $\begingroup$ @Theo: Yes, that doesn't help, but disabling the fonts and restarting the browser did help ;-). $\endgroup$ – Jonas Teuwen Jul 27 '11 at 14:11
  • $\begingroup$ Thanks for the help everyone. I did manage the right-click :-) but as Jonas said, changing the renderer didn't help - in fact it looks much worse with MathML. The STIX disabling trick certainly did work. $\endgroup$ – Alon Amit Jul 27 '11 at 17:39
  • 3
    $\begingroup$ @Alon: I don't have a problem. It might be worth mentioning which browser you are using... $\endgroup$ – Zhen Lin Jul 29 '11 at 8:20
  • 1
    $\begingroup$ Here is the MathJax bug tracker for the problem. It appears to affect only Safari; the bug reporter there says Opera renders math as expected, and I too see the problem in Safari but not in Firefox. $\endgroup$ – Rahul Dec 20 '11 at 23:06

I have a workaround. Go to Font Book and disable the STIX fonts (you can find them by entering "stix" in the search bar) by selecting all of them and pressing the button with a "V" on it.

After that close your browser because it probably has loaded the fonts in its memory.

This worked for me, but the site loads a little bit slower. The STIX fonts that are installed also look much better elsewhere than with MathJax, so I'm not sure if manually installing them again would help much.

  • 1
    $\begingroup$ Great - thanks Jonas! This worked for me. I'll need to do some reading about this, not sure what those fonts actually are and what's the cost of disabling all of them. $\endgroup$ – Alon Amit Jul 27 '11 at 17:37
  • 1
    $\begingroup$ @Alon: I don't think there is a problem disabling them. If I understood correctly, these fonts were not in OS X 10.6 and there didn't seem to be a problem. $\endgroup$ – Jonas Teuwen Jul 27 '11 at 17:43
  • 1
    $\begingroup$ Worked for me too; thanks, Jonas! $\endgroup$ – Adrian Petrescu Dec 20 '11 at 8:23

I wrote a bug report on Meta SO since this applies across all SE sites with MathJax, and the user shouldn't have to apply a workaround.

I also observe that the nature of the problem seems to be that (with few exceptions) many things which should be roman are italic, and everything which should be italic is extra-super-italic. Note the difference in the foos:


It appears that the problem is that Lion ships with version 1.0.0 of the STIX fonts; one workaround is to download version 1.1.0 from the STIX website.

  • $\begingroup$ So, to render well we have to install beta-version fonts? $\endgroup$ – GEdgar Dec 21 '11 at 16:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .