2
$\begingroup$

I just noticed that I earned the "Excavator" badge a few minutes ago, putatively for a post that was "deleted or otherwise unavailable". So, apparently, did dozens of other people. I don't recall making any edits to old posts recently. What's going on?

| |
$\endgroup$
  • 3
    $\begingroup$ It's a new badge just introduced. Let's wait a little. $\endgroup$ – Grigory M Aug 15 '11 at 9:09
  • $\begingroup$ I agree with Grigory M. I guess that when it is implemented correctly, however, it will be retroactive, so you will receive it if at some point in the past you edited a long unactive post. $\endgroup$ – Jonas Meyer Aug 15 '11 at 9:18
  • $\begingroup$ ...and indeed it's fixed already. $\endgroup$ – Grigory M Aug 15 '11 at 9:54
  • 1
    $\begingroup$ @Grigory: Fixed, apparently... But I'm wondering why they removed the question you linked to (I haven't seen it). $\endgroup$ – t.b. Aug 15 '11 at 11:48
6
$\begingroup$

There were some minor glitches in the intial awarding which caused people to earn multiple iterations of the badge (it's a one-time deal). Consequently, to handle this, we rolled out a fix that unawarded all of the badge instances, then re-awarded them afterwards. Getting the badge but having no associated question was probably an artifact from that process, but it is since no longer present.

You rightfully have the badge attributed to this post edit last month, which was to a year-old post. It was only awarded recently, rather than at the date of the fact, because the badge was only just introduced.

| |
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .