So the election for a new moderator are at the last phase and after reading what the candidates have to say I voted, and so I got Constituent.

From the moment I got that badge the site does not show me reputation change at the top:enter image description here

But the reputation does change in number and the change appear at the reputation tab at my profile:enter image description here

It is the first time I see this, so maybe there is connection between the two but I really have no idea.

  • 5
    Yes, I've noticed this same issue. In this screenshot, for example, you can see that I've received 50 points in upvotes today that are not reflected in the 'recent achievements' menu that I've pressed. – Mark McClure Aug 7 at 2:53
  • @MarkMcClure I see, so it is probably have nothing to do with the Constituent badge. – Holo Aug 7 at 11:12
  • 1
  • I witnessed the same issue, but it seems to be fixed now - the system gradually caught up. – Arnaud Mortier Aug 7 at 15:30
  • @DanielFischer it seems like it got fixed, should you add the tag [status-complete]? – Holo Aug 7 at 16:01
up vote 4 down vote accepted

Copying this answer from Nick Craver♦ on SO:

Our aggregation queue got jammed up with a bad item here (and we'd rather stall that discard data since it's terribly expensive to analyze and fill gaps after the fact). The bad entry has been handled (data wider than the column in 1 path) and we're now draining. Since we were at 2.25 million items it'll take 10-20 minutes or so to drain out.

Once that happens, everything should be back in place.

  • 1
    I don't understand a single thing Nick said (and I'm a CS professor!!) but... glad it's being handled? – user7530 Aug 7 at 17:37

I often do not see reputation changes around the time of a User was removed message. As I also had reputation changes this week which did not show up, and had a User was removed with -85 reputation, I think this may be the explanation.

I believe the site is programmed to suppress reputation change notifications if the total change is negative. For example, I sometimes see a $+8$ notification when there was a downvote, followed by an upvote, but the initial $-2$ does not generate a notification. For your case, however, it looks like the total change was positive, so maybe the conditions for notification are more complicated than I thought.

  • 3
    While this a relevant piece of information in that context, I am not convinced by this explanation for the current scenario for two reasons. First, the numbers don't add up. OP did not take a larger point penalty recently, or also @MarkMcClure only lost 30 yet gained 50, thus it should show at least the last +20. Second, and more importantly, while the notification might not be shown, in the sense that no green +10 will appear in the top-bar upon the vote, the record is not suppressed in the tally one sees when expanding. – quid Aug 7 at 8:33
  • 3
    Concerning the suppression of notifications when a negative reputation event happened, it's worth noting that a) that suppression considers network-wide reputation changes (so if you lose say 20 points on SO because of a user/post deletion, downvotes, whatever, you don't get a notification until you earned more than 20 points on all sites combined), and b) notifications begin again regardless of overall change when one opens the achievements dropdown. But in line with quid's second point, I think this one has a different cause. – Daniel Fischer Aug 7 at 9:17
  • 1
    While I appreciate the reply, just like quid and D.Fischer said, you are probably talking about different matter all together. About the reputation change you had, a pretty 'big' user delete his account and there were a big rep change because of that(luckily I didn't got too effected from this) – Holo Aug 7 at 11:11
  • Agree with quid and Daniel Fischer. This answer is just speculation. – 6005 Aug 7 at 15:39
  • I disagree; I too have witnessed notification irregularities near “user removed” events and wouldn’t be surprised if that’s part of the story. – user7530 Aug 7 at 16:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .