The letter T in CRT is too small below (source here). This is the only letter in the alphabet that exhibits this problem in that context. Alas, it renders so ugly that I've been forced to resort to alternatives such as the $\!\bmod\!$ Distributive Law (just kidding, but it is a bit hard on my eyes).

enter image description here Platform: Chrome 74.0.3729.131 on Win7 at 100% zoom.

  • 3
    $\begingroup$ Looks fine on my computer (Arch Linux, Chromium) $\endgroup$ – Asaf Karagila May 11 at 22:32
  • $\begingroup$ I just recalled this old post which may be related. $\endgroup$ – Bill Dubuque May 11 at 22:45
  • 1
    $\begingroup$ Does it look any better for you if you use \text{CRT} rather than {\rm CRT}? Also, what output renderer are you using? $\endgroup$ – Davide Cervone May 12 at 17:53
  • $\begingroup$ @DavideCervone Alas, that doesn't help. It goes away at $110\%$ zoom, but it is still there all other neighboring zoom values $75,80,90,100,125,150,175\%\ \ \ $ $\endgroup$ – Bill Dubuque May 12 at 18:17
  • 1
    $\begingroup$ @Davide I'm using the default MathJax settings, renderer = HTML-CSS, MathJax.js v2.7.5 TeX Input Jax v2.7.5 HTML-CSS Output Jax v2.7.5 PreviewHTML Output Jax v2.7.5 mml Element Jax v2.7.5 $\endgroup$ – Bill Dubuque May 12 at 18:21
  • $\begingroup$ @BillDubuque, is it any better if you switch to CommonHTML? I assume SVG would not show this artifact. $\endgroup$ – Davide Cervone May 12 at 22:11
  • $\begingroup$ Also, thanks for trying out \text. $\endgroup$ – Davide Cervone May 12 at 22:17
  • 1
    $\begingroup$ @Davide Right, no problem with SVG. With CommonHTML it is bad at 80,90% and good at 75,100.110,125%. $\endgroup$ – Bill Dubuque May 12 at 22:26
  • 1
    $\begingroup$ @BillDubuque, I suspect that the issue is that the MathJax fonts are not well hinted. I'm not a font expert, but in my experience, font hinting has always been much more critical in Windows, and the results, especially at small sizes, have typically been poorer there. It looks the top of the T may be one pixel low, probably due to a difference in rounding. Both the outlines themselves, and the hinting, were algorithmically generated, and that leads to some variation in the control point positions from letter to letter, and so to potential rounding problems. $\endgroup$ – Davide Cervone May 12 at 23:35
  • 1
    $\begingroup$ You might try switching to the STIX fonts or one of the other web fonts to see if there is a difference (in HTML-CSS -- they aren't available in CommonHTML). Try entering MathJax.Menu.showFontMenu(true) in the browser console windows that should make an extra menu available in the MathJax contextual menu. Choose STIX (Web) in the font submenu of the math setting menu and see if that helps (it will reload the page in order to make the change). $\endgroup$ – Davide Cervone May 12 at 23:38
  • $\begingroup$ @Davide If I change the defaults then I would no longer see how my posts render for the majority of readers (who presumably use the defaults). $\endgroup$ – Bill Dubuque May 12 at 23:49
  • $\begingroup$ @BillDubuque, actually a number of people will be getting STIX fonts automatically from HTML-CSS output. Those who have STIX installed locally (and idon'thave MathJax fonts installed locally) will have output using STIX. For example, Xander's screen snapshot appears to be using the STIX fonts. So switching to STIX it not necessarily bad, and does represent what a number of people will see. $\endgroup$ – Davide Cervone May 13 at 10:07
  • $\begingroup$ I see the same thing that @BillDubuque sees; I'm on a Windows 10 PC using Chrome. As far as I'm aware, everything is at the default setting. $\endgroup$ – Clayton May 13 at 11:38
  • 1
    $\begingroup$ @Davide What are the current defaults for renderer and fonts? Are they context dependent? $\endgroup$ – Bill Dubuque May 13 at 12:48
  • $\begingroup$ @Davide To fix the font hints for the T where should I look? (a long time ago I worked on font hinting for Bitstream). $\endgroup$ – Bill Dubuque May 13 at 17:46

(Posted as an answer, as comments don't support images)

This seems to be a problem with whatever software you are using. Under Opera version 58.0.3135.132 (under Mac OS), I see the following:

enter image description here

Perhaps you could specify the browser you are using?

  • 2
    $\begingroup$ What level Zoom are you using? $\endgroup$ – Bill Dubuque May 11 at 22:32
  • 1
    $\begingroup$ @BillDubuque Whatever the default is. It looks fine under Chrome and Safari, too. Again, it would be helpful to know what your configuration is, as it would appear that neither Asaf nor I see what you are seeing. $\endgroup$ – Xander Henderson May 11 at 22:33
  • 1
    $\begingroup$ It is now in the OP. Thanks for checking on your platform. $\endgroup$ – Bill Dubuque May 11 at 22:35

On a $64$-bit Win$7$ computer, accessed through a remote terminal connection, using FireFox $66.0.5$, I can reproduce the problem, but only at $100$% zoom. At $90$% or $110$%, it looks fine. However, on the same machine, using the same version of Chrome $74.0.3729.131$ as you have, the problem doesn't occur at $110$%, $100$%, $90$% and $67$% zoom, but it does happen at $80$% & $75$% zoom. On a $64$-bit Windows $10$ machine, with a $1280$x$1024$ resolution, using Microsoft Edge version $44.17763.1.0$, the problem occurs at all zoom levels I tried, i.e., $50$%, $75$%, $100$%, $125$% and $150$% (but it seems to be minimal for the $125$% & $150$% zoom).

If need be, I can try different OS's & browsers, but I believe what I've described above shows there is no simple pattern and, perhaps, no simple solution. Overall, I suspect it depends on various factors, including the fonts being used, the screen resolution, the MathJax renderer, the browser, the OS, etc.

  • 2
    $\begingroup$ Yes, it probably depends on motley factors and is likely related to the $x$-waves bug I reported a few years ago. If only it didn't occur on such a frequently used term. Thanks for the troubleshooting help. $\endgroup$ – Bill Dubuque May 11 at 23:35
  • $\begingroup$ @BillDubuque You are welcome for the troubleshooting help. My biggest display issue is with how numeric digits are shown by default. To avoid that, I usually show them inside MathJax statements instead. For me, it's still not completely correct, but it's noticeably better. $\endgroup$ – John Omielan May 12 at 0:00



Works in my browser currently ( with htmlcss or SVG renderer, all of common html,preview html makes the T bigger) but seems a little annoying to type out. chrome version 76 something at my local library.

  • $\begingroup$ I was on a desktop, but on mobile ( beta browser) now the t looks too big. $\endgroup$ – Roddy MacPhee Aug 26 at 14:41
  • $\begingroup$ Here the T looks too small. $\endgroup$ – quid Aug 26 at 15:44
  • $\begingroup$ is it any bigger than the original ? $\endgroup$ – Roddy MacPhee Aug 26 at 15:45
  • $\begingroup$ It looks smaller than the C and the R; it looks mostly like in screen shot in OP. $\endgroup$ – quid Aug 26 at 15:46
  • $\begingroup$ At zoom 90% and 110% the look the same size, the CRT I mean. I did not yet find one where the T looks larger. $\endgroup$ – quid Aug 26 at 15:47
  • $\begingroup$ $$\stackrel{CRT}{\iff}$$ $\endgroup$ – Roddy MacPhee Aug 26 at 15:52
  • $\begingroup$ The comment looks good to me. $\endgroup$ – quid Aug 26 at 16:44
  • $\begingroup$ uses stackrel instead of overset. an equivalent mentioned in the LaTeX wikibook. $\endgroup$ – Roddy MacPhee Aug 26 at 17:24
  • $\begingroup$ only difference I can spot in developer mode is that one uses italics versions the other doesn't seem to. $\endgroup$ – Roddy MacPhee Aug 28 at 13:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .