26
$\begingroup$

I have noticed in the last two weeks or so that after clicking the "An edit has been made ..." banner, the mathjax is not rendered.

Example (before): before image

(and after): after image

Refreshing the page renders the mathjax again. Is this a (new) feature? And if not can something be done?

I am using Firefox 68.0.2 on Windows 7.

$\endgroup$
16
  • 7
    $\begingroup$ I'm experiencing the same thing on Chrome Version 76.0.3809.100, Windows 10. $\endgroup$
    – Zacky
    Commented Aug 16, 2019 at 13:43
  • 4
    $\begingroup$ Add me too in the list! $\endgroup$
    – 19aksh
    Commented Aug 16, 2019 at 14:04
  • 1
    $\begingroup$ Happens on Firefox 68.0.2 on Unix, and on Windows 10. I just re-load. $\endgroup$ Commented Aug 16, 2019 at 14:57
  • 1
    $\begingroup$ My experience is that the MathJax eventually renders again, but it takes a long time (maybe 30 seconds). $\endgroup$ Commented Aug 16, 2019 at 17:09
  • 1
    $\begingroup$ Sometimes happens on Chrome. Indeed it renders again but it doesn't last too much. At most 2-3 seconds. $\endgroup$
    – user486983
    Commented Aug 16, 2019 at 17:38
  • $\begingroup$ nevermind. I have just seen an edited question and the mathjax is not rendered unless refreshing the page. It's the first time this happens, time ago it was 2-3 seconds and sometimes. $\endgroup$
    – user486983
    Commented Aug 16, 2019 at 18:27
  • 1
    $\begingroup$ Same problem with Opera 62.0.3331.119 for Mac. Reloading causes the MathJax to render. It has been this way for a couple of days now. $\endgroup$
    – Xander Henderson Mod
    Commented Aug 16, 2019 at 23:43
  • $\begingroup$ Migh be related to here where MathJax slowed down after questions were closed (this is still not completely fixed, see my comments there). $\endgroup$ Commented Aug 17, 2019 at 0:24
  • $\begingroup$ @EricWofsey Using FireFox version $68.0.1$ on Windows $7$, I noticed very similar behavior, i.e., it takes quite a while (about $30$ or so seconds as you mention) for MathJax to render on its own. However, refreshing the screen seems to always cause it to render again considerably faster. $\endgroup$ Commented Aug 17, 2019 at 1:25
  • $\begingroup$ Using Chrome 76.0.3809.100, I found that the problem has now disappeared. Anyone else experience the same thing? $\endgroup$
    – Toby Mak
    Commented Aug 25, 2019 at 12:38
  • $\begingroup$ Using Chrome Version 76.0.3809.132 and I still have the problem. $\endgroup$
    – saulspatz
    Commented Aug 31, 2019 at 17:11
  • 2
    $\begingroup$ (1) It is perhaps worth noting that this is still an issue (see here). (2) As a workaround, the MathJax bookmarklet can be used without forcing a reload. $\endgroup$
    – Xander Henderson Mod
    Commented Oct 21, 2019 at 19:34
  • $\begingroup$ Same problem here, with Safari on a Mac. $\endgroup$ Commented Oct 21, 2019 at 21:26
  • $\begingroup$ Same problem using Chromium 77.0.3865.90 on Linux (Fedora 30), dating back to slightly before the current post (persisting through both browser and OS updates). $\endgroup$
    – hardmath
    Commented Oct 22, 2019 at 23:36
  • 2
    $\begingroup$ This needs to be fixed! There's no reason, at least as a work-around, that clicking the "An edit has been made to this post" link shouldn't auto-refresh the webpage. $\endgroup$ Commented Dec 12, 2019 at 20:16

1 Answer 1

8
$\begingroup$

This has been fixed.

I'm embarrassed to say this was originally my fault. I had refactored post reloading to fix a handful of small bugs in support of moderator tooling, and accidentally dropped the call to styleCode() that kicks off the MathJax rendering.

If you're familiar with browser debugging tools and want to verify for yourself that this is fixed without waiting for a question to get edited, you can run the following JavaScript to force a question to update:

StackExchange.realtime.reloadPosts([$('.question').data('questionid')])
$\endgroup$
5
  • $\begingroup$ I have no idea what a "browser's console" is, much less how to "trigger" something in it. $\endgroup$ Commented May 7, 2020 at 22:52
  • 1
    $\begingroup$ @GerryMyerson Sorry about that, I've updated my answer. It was just some added context on a way to simulate a reload for users who have web development experience. The problem should be fixed and you don't need to take any actions. $\endgroup$ Commented May 7, 2020 at 22:57
  • $\begingroup$ Great. This was really annoying. $\endgroup$ Commented May 8, 2020 at 0:15
  • 1
    $\begingroup$ This is not fixed on the unanswered questions page. When there are new questions and you click to expand them, the MathJax doesn't render. $\endgroup$ Commented May 12, 2020 at 21:24
  • $\begingroup$ I still see this problem on the active questions page as well. I can use the "render MathJax" bookmarklet to render, or reload the whole page. $\endgroup$
    – robjohn Mod
    Commented Jun 22, 2021 at 9:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .