3
$\begingroup$

Yesterday evening there were two posts in Meta - here, and here - concerning display problems. Simultaneously, on the main MSE site, I was noticing that comments containing MathJax could no longer be read. The details of the problems reported in the two Meta posts were different (i.e. they were different from each other, I think, and they were certainly different from the problem I was having), and no-one else mentioned, even in passing, that they were having any difficulty in viewing comments. Nor has there been any mention today of the problems that were reported yesterday. Meanwhile, for me, nothing has changed.

For example, a few days ago I posted a comment that began:

Doesn't it just mean a proposition concerning $x$ and $y$ [$\ldots$]

Like all the other comments I'm talking about, this was rendered normally at the time it was posted. Since yesterday evening, however, it has looked like this:

Image of comment

How insulting! :)

As this example illustrates, even simple uses of MathJax cause problems. That particular comment was a long one, but short comments are also affected. Comments by other users are affected in the same way as my own. (This makes reading the site very difficult!)

I have switched between the HTML-CSS and SVG math renderers, and it makes no difference.

I have not tried clearing my browser cache, partly because this is an often-touted general cure that in my experience has never worked for any problem (whereas every problem has always had a specific solution), and partly because I don't want to risk losing my browsing history, which I refer to several times a day.

I have rebooted Windows and restarted Firefox, without effect. I have also viewed the above comment on another PC, using a different operating system, and an installation of Firefox that has seldom been used to visit MSE, and the problem there is exactly the same.

The problem seems to be specific to Firefox, because the same comment renders normally when I use Opera, even a very old version (2013).

Talking of age: both my computers are very old. One uses Windows XP, the other Windows Vista. I am in the process of replacing both machines, but it is a slow business.

I'm half-resigned to discovering that this problem is yet another good reason for making that long-delayed change. Still, I'm surprised that no-one else has reported the same glitch, so I'm reporting it now.

$\endgroup$
  • 1
    $\begingroup$ Clearing your cache should be possible without losing your history. The history is simply a list of URLs which you have visited; the cache is a local copy of files which you have downloaded (e.g. images, style sheets, etc) which help the browser to render pages faster and limits the amount of redundant downloading. $\endgroup$ – Xander Henderson Dec 5 '19 at 20:08
  • $\begingroup$ @XanderHenderson Thanks, I'll bear that in mind, and perhaps I'll even try it out (on my other machine, first). By the way, another problem I've noticed with comments since last night is that when I try to upvote someone else's comment - as I have just tried to do with yours - nothing seems to happen. So : "(+1)". I hope that will do instead! :) ... Ah, the upvote has appeared. Perhaps this behaviour of the system is normal, and I'm just worrying that everything is part of this new glitch. $\endgroup$ – Calum Gilhooley Dec 5 '19 at 21:55
  • $\begingroup$ I cleared Firefox's cache on my backup machine - ignoring most of the advice I found on the Internet, which would indeed have lost me my browsing history, too - and viewed the page containing the comment quoted above. It still looks the same. I told you so! :) $\endgroup$ – Calum Gilhooley Dec 5 '19 at 23:31
2
$\begingroup$

I see in your example comment the time is not showing, so I believe there's a fairly good chance your problem is related to what was reported in the main meta site at Comments not showing time of posting under some circumstances. Note that Robert Longson's answer says

Support for older/obsolete browsers has been removed recently, specifically browser prefixing.

Note, though, a later question of Comments missing timestamp and MathJaX in Firefox ESR 52 (2019), as it mentions problems with MathJax in FireFox, is possibly more relevant, but as as of when I wrote this, there's no answer to it.

The timing of the change (i.e., occurring just before you noticed your problem), both of your computers being old (so I assume their browser versions are fairly old), that not too many people seem to have noticed this (including myself, with my checking to confirm MathJax shows properly in comments, such as in this one with my use of the latest version of FireFox on Windows $7$), and the relative likelihood (as far as I know) that "browser prefixing" and/or some other change they made to remove support for "older/obselete browsers" (note this answer lists the minimum versions of browsers required), is involved with handling MathJax in comments, makes this seem to me like a likely candidate. To determine this for sure, though, I suggest you ask about this in a comment in the main meta's and/or StackOverflow post to Robert, or ask a new question on the main meta about this issue.

Good luck with determining what the cause is and, hopefully, also getting comments (and anything else related which is failing) working properly again.

$\endgroup$
  • 1
    $\begingroup$ @CalumGilhooley Note I just added a link to a new main meta question which appears to be more pertinent. $\endgroup$ – John Omielan Dec 6 '19 at 15:41
  • $\begingroup$ Of the workarounds here, the first doesn't work on the new glitch, but the second, "open and close the Web Developer Inspector panel (Cntrl+Shift+C)", works brilliantly. This is for Firefox ESR 52.9.0 (32-bit). $\endgroup$ – Calum Gilhooley Dec 6 '19 at 18:12
  • $\begingroup$ @CalumGilhooley That's great! I'm glad you now have FireFox working again. $\endgroup$ – John Omielan Dec 6 '19 at 18:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .