I am having troubles in mathjax escaping braces with backslash while on math stack exchange using firefox version 72.0.1. Although it the escaped braces render when the question is posted, they do not render while the question is being edited. This is of course not a huge issue because the braces do render in the actual post however it is a bit annoying to not be able to see what the post will look like until it has been posted. To illustrate the problem I have taken screenshots which can be viewed below:

enter image description here

enter image description here

In particular, notice the braces are missing in the preview of the post. This can be seen in the second picture. The first picture simply verifies that the final post did in fact render the braces correctly.

I have now included another picture to address a question asked in the comments about the version of mathjax I am using. I still don't really know what that is about, I have never changed any settings so I assume I'm using the default for everything, however in any case I have taken a screen shot and hopefully it contains the information needed. If it does not please give me specific instructions on where to find whatever is needed.

enter image description here

Also, I just tried to replicate this problem and was unable to as shown in the following screenshot:

enter image description here

So at this point I might conclude that the problem has been resolved, however I'll leave this question open in case something more complicated is going on. As you can see in the original screenshots this bug was present at the time of my original post so something has changed.

  • 1
    $\begingroup$ I have added the screenshots directly into the post, I hope that it's ok. (Images uploaded directly through the editor should be less likely to stop working, see here: Permanent Picture Uploads.) $\endgroup$ Commented Jan 10, 2020 at 0:27
  • 1
    $\begingroup$ thanks for this, I was trying to do the same thing as you at the same time $\endgroup$
    – Mathew
    Commented Jan 10, 2020 at 0:27
  • $\begingroup$ Using \$\left \{ blah \right \}\$ might help. $\endgroup$ Commented Jan 10, 2020 at 16:28
  • $\begingroup$ It would be helpful to know what your MathJax settings are (on the main site). $\endgroup$
    – hardmath
    Commented Jan 11, 2020 at 0:20
  • $\begingroup$ I don't know how to find that out $\endgroup$
    – Mathew
    Commented Jan 11, 2020 at 7:24
  • $\begingroup$ On the main site, if you highlight some formatted maths with your mouse and right-click a pop-up menu appears. Select Math Settings from there and make a note of the values under the Math Renderer item. I think this may be what hardmath is referring to. $\endgroup$ Commented Jan 11, 2020 at 15:47
  • $\begingroup$ @PeterPhipps, thanks for the information, I have tried my best to answer hardmath question by modifying my post. $\endgroup$
    – Mathew
    Commented Jan 13, 2020 at 1:49
  • $\begingroup$ @hardmath, I have modified my post to hopefully answer your question, if I have missed something you need to know, please tell me and I will do my best to get you what you need. $\endgroup$
    – Mathew
    Commented Jan 13, 2020 at 1:50
  • $\begingroup$ I will add this link to the above comments: How do I change Math Renderer for MathJax? For example, this bug appeared with renderer set to HTML-CSS but not with SVG. $\endgroup$ Commented Jan 13, 2020 at 3:00
  • $\begingroup$ You were close, but the information to be discussed (under Math Settings , the Math Renderer item) is not shown in your latest image. You highlighted the Show Math As options instead. $\endgroup$
    – hardmath
    Commented Jan 13, 2020 at 3:47
  • $\begingroup$ Let me just say that when I try the same thing, I see the braces: i.sstatic.net/IiNoB.png The screenshot was taken in Google Chrome Version 79.0.3945.117. Math Renderer is HTML-CSS. $\endgroup$ Commented Jan 13, 2020 at 4:15
  • $\begingroup$ I have recently occasionally ran into similar problems with TeX-code not getting fully interpreted in the preview pane, but turning out ok when posting it as an answer. Later on the problem disappeared. I'm not sure whether the total amount of TeX-code in the post played a role? I use Firefox. $\endgroup$ Commented Jan 13, 2020 at 5:54
  • 1
    $\begingroup$ @hardmath, I have taken a new screenshot, hopefully this has the relevant information, sorry for the confusion earlier. Please note however the problem seems to have gone away as you can see by my latest screenshot. That being said, maybe the fact that this was a bug at one point is still worth pursuing. I'll let the rest of you guys decide on that. $\endgroup$
    – Mathew
    Commented Jan 14, 2020 at 3:23
  • 1
    $\begingroup$ Just FYI there's sandbox for long drafts and MathJax sandbox so that you can do tests (not just previews but also submission) and not cause any confusion. Supposedly they work exactly like a "proper" post on the main site. $\endgroup$ Commented Feb 24, 2020 at 23:59
  • 2
    $\begingroup$ On MathOverflow Meta: Braces are not rendered in MathJax in the preview of a question. $\endgroup$ Commented Feb 10 at 5:25


You must log in to answer this question.

Browse other questions tagged .