7
$\begingroup$

I voted to close this post as a duplicate of this other post recently, and the OP agreed with the close vote about an hour ago. Unfortunately, for some reason, the duplicate target header just reads "This question already exists:" with no link to the duplicate target. Here is a picture in case this issue is specific to me:

enter image description here

This seems like a bug, so here I am making a bug report. For reference, this other question was marked as a duplicate 10 hours ago and displays all the expected behavior for me - namely, the link to the duplicate post actually shows up on the page.

EDIT: As Xavier Henderson/Martin R point out, this is a known bug on the StackExchange side. Here is a post on the StackExchange meta site dealing with this issue.

EDIT 2: Asaf Karagila has used moderator powers to fix this specific instance, but the underlying bug is still active, per the meta.stackexchange post referenced in the first edit.

EDIT 3: Stack Overflow developer Yaakov Ellis has provided an answer on meta.stackexchange. I have included that post as an answer below.

| |
$\endgroup$
  • $\begingroup$ Thank you. I've seen that in a previous question and thought it might have been a singular occurrence. $\endgroup$ – Asaf Karagila Apr 4 at 19:39
  • $\begingroup$ The "some reason", I suspect, is when the OP agrees with the duplicate suggestion. $\endgroup$ – Asaf Karagila Apr 4 at 19:46
  • $\begingroup$ @AsafKaragila Here is an example where the OP agreed with a duplicate suggestion, but the dialog behaved appropriately. It is from 2/29/2020, so it is not as recent, but it was one I could remember off the top of my head. $\endgroup$ – KReiser Apr 4 at 19:51
  • 2
    $\begingroup$ Martin R says that this is a known bug: meta.stackexchange.com/questions/345289/… $\endgroup$ – Xander Henderson Apr 4 at 20:11
  • $\begingroup$ @XanderHenderson thank you, I've updated the post with that information. $\endgroup$ – KReiser Apr 4 at 20:37
2
$\begingroup$

Stack Overflow developer Yaakov Ellis has provided an answer on meta.stackexchange:

Update: This issue has hopefully been fully addressed, the fix is on all network sites.

The issue itself had to do with cases where either the poster or the user who raised the close flag had low enough rep that they could not yet access the review queue, and thus the system marked their flag as a RecommendedClose. This led to weird scenarios in which the closing mechanism would accept the self-close action of the poster (following the recommendations for duplicate posts given in the post notice), but the system failed to record the actual OriginalDuplicateQuestionId value for the post (leading to the empty list).

Thanks to Adam Lear as well for help with this. We are pretty sure that we have identified the root issues here, and have added unit tests as well to verify the fix. I have also added logging here that will record more details in any cases where this will happen again moving forward. If you see any (with question closed after this update), please report them in a comment.

There is no easy way to retroactively fix all posts affected by this. However, mods and gold-tag users should be able to use the Edit function given at the top of the duplicate post notice to add back the missing duplicate question (without having to reopen and close).

Thanks everyone for your patience with this and for your help reporting instances where this occurred.

| |
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .