5
$\begingroup$

I was reviewing the "First answers" queue when I was presented with this post (*): it is clearly not an answer, so I flagged it as NaN and then I also clicked on the "Delete" button on the right side of the page: I was shocked to see a pink popup appear with the text "You cannot delete this answer". Is this a bug? If not, what is the reason for this surprising behaviour?


(*) If you clicked on it and you didn't find anything meaningful, then it must have got deleted already and you have less than 10000 reputation, so you can't see deleted posts.

$\endgroup$
13
  • $\begingroup$ Is it because the net upvote is non-negative? $\endgroup$ Aug 31 at 14:23
  • $\begingroup$ I had the same (did not track details carefully), but I had the same post pop up in a separate queue earlier (well, I opened both queues at the same time) where I had already flagged it. I retracted my flag but still could not delete $\endgroup$ Aug 31 at 14:24
  • $\begingroup$ It looks like the answer got deleted now. $\endgroup$ Aug 31 at 14:34
  • $\begingroup$ Weird: some other managed to vote to delete though.... (FYI: the related low quality review) $\endgroup$ Aug 31 at 14:37
  • $\begingroup$ @ArcticChar just fyi: it seems Xander deleted the answer, he and Harish are the two delete votes $\endgroup$ Aug 31 at 14:45
  • 1
    $\begingroup$ It's interesting that Harish managed to vote to delete in LQ review queue, while Alex can't in First answer queue. $\endgroup$ Aug 31 at 14:54
  • $\begingroup$ @Alex are you having details regarding whether the answer has score more than $-3$ or equal to $-3$ or less than $-3$ $\endgroup$
    – user876009
    Sep 1 at 1:22
  • $\begingroup$ @JitendraSingh: It had 0 upvotes and 0 downvotes. Completely neutral. $\endgroup$
    – Alex M.
    Sep 1 at 8:07
  • $\begingroup$ @AlexM. that is why you were unable to delete the post. A answer must have score <-1 for choosing deletion though any score is fine if you click on recommend deletion though you can't choose recommend deletion because you have the privege of deletion. $\endgroup$
    – user876009
    Sep 1 at 9:42
  • $\begingroup$ @JitendraSingh: I somewhat understand what you are saying, although I consider this algorithm so unnatural that I still think of it as a bug. The SE staff should take a look at it, in my opinion. A moderator tagged my question as "status-review", so hopefully someone will investigate this further. $\endgroup$
    – Alex M.
    Sep 1 at 9:45
  • $\begingroup$ You could have addressed this by downvoting the post - if you thought it was deletion-worthy, downvoting seems reasonable? $\endgroup$
    – Catija StaffMod
    Sep 8 at 15:22
  • $\begingroup$ @Catija: I was reporting what looked (and still looks) like a bug. I was not asking about what to do when reviewing posts, at more than 7 years on MSE I already know that. $\endgroup$
    – Alex M.
    Sep 8 at 15:25
  • $\begingroup$ Sure, we want to double check that the behavior here hasn't changed - that it's consistent from the old first posts queue as much as possible. But technically it's working as designed since you can't delete posts that have zero score. It's unclear to me whether this has changed or not so my comment was more to advise you on how to address this if you run into it again. If you can't vote to delete for some reason, there's no reason to show you the button. $\endgroup$
    – Catija StaffMod
    Sep 8 at 15:30
2
$\begingroup$

We've confirmed that this isn't a new bug related to our recent Review Queues launch. The inability to delete in this case was based on existing rules, so it's . We considered greying out or hiding the Delete link on posts when a post doesn't meet the rules, but this had larger implications because it would touch other places in the site, such as the main question page, not just Review Queues.

$\endgroup$
1
  • $\begingroup$ Is it the same as what Catija said: because it had net score 0, he couldn’t vote to delete? Was the post deleted by mod veto? And how did it gain a delete vote by a non mod? $\endgroup$ Sep 15 at 1:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .