15
$\begingroup$

This has never happened before on SE, not even earlier today in a different stack.

I wrote a question and clicked "post." Immediate pop-up "Are you sure you want to leave this page?" I assumed (incorrectly) that something had gone wrong. So I said No and tried again. oops! duplicate post.

Then I saw a typo and tried to fix it. When I clicked Save, same pop-up, with a busy spinner on the Save button. Clicked yes (leave), and saw that the edits had actually been saved.

$\endgroup$
9
  • $\begingroup$ It did not happen when I posted this question. However, when I edited the question it did happen, AND an earlier version of this comment disappeared. $\endgroup$
    – WGroleau
    Jan 11 at 23:22
  • 3
    $\begingroup$ @WGroleau I just got basically the same behavior as you, using Microsoft Edge on a Windows 10 machine. When I clicked "Cancel", my answer showed as being blank! However, refreshing showed that the edits were saved. Like you, this has never happened before, and I haven't made any recent machine changes (e.g., any updates). Thus, I suspect SE has changed something recently to cause this to happen. I'm not sure if this is just on the Math site, but you may wish to check if it's also on other sites and, if so, write a bug report on the general Meta SE site. $\endgroup$ Jan 12 at 0:43
  • 6
    $\begingroup$ @WGroleau FYI, this is already reported on Meta at Editing a post leads to a weird behavior. A comment there indicates it's also been reported on meta StackOverflow at Getting "You have started editing this post. Abandon this edit?" when saving an edit. $\endgroup$ Jan 12 at 0:58
  • 3
    $\begingroup$ Ditto for me, WGroleau, and @JohnOmielan! Using Firefox. $\endgroup$
    – amWhy
    Jan 12 at 1:28
  • 1
    $\begingroup$ I can confirm it occurs on Safari when you edit an answer too. $\endgroup$
    – user400188
    Jan 12 at 5:16
  • 3
    $\begingroup$ I'm having the same issue with posting answers as well. $\endgroup$ Jan 12 at 5:37
  • $\begingroup$ Same error happens to me, too (using both latest Firefox and Chrome on Win10) $\endgroup$
    – 5xum
    Jan 12 at 8:35
  • $\begingroup$ Yes, I am seeing this when editing answers. $\endgroup$ Jan 12 at 11:12
  • 2
10
$\begingroup$

First of all: thanks a lot to everybody for notifying us about this issue. We have been able to reproduce and fix the issue. Please do let us know (in a comment to this answer) if you're still encountering any issues with this.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .