28
$\begingroup$

I'm seeing [Math Processing Error] all over this site today. Is there a bug or is this problem unique to me? How do I fix it? Thanks.

$\endgroup$
  • 6
    $\begingroup$ Have you tried Shift-Refresh? $\endgroup$ – J. M. is a poor mathematician Feb 10 '12 at 15:27
  • $\begingroup$ I'm also seeing this everywhere on the site with Chrome, but it seems to work with Firefox $\endgroup$ – Mad Scientist Feb 10 '12 at 15:28
  • $\begingroup$ I was just googling the same thing. I have the same problem with Chromium 16, in linux. $\endgroup$ – Bruno Stonek Feb 10 '12 at 15:42
  • 4
    $\begingroup$ @J.M. Shift-Refresh worked. Could you fill in some details? What is Shift-Refresh and why was I having the problem? Thanks. $\endgroup$ – Jeff Feb 10 '12 at 15:44
  • 6
    $\begingroup$ It means crap got in your browser cache. Shift+Refresh forces your browser to pull JS and other stuff anew instead of getting them from the cache. $\endgroup$ – J. M. is a poor mathematician Feb 10 '12 at 15:48
  • $\begingroup$ Is there a version of Shift-Refresh for iPhone? $\endgroup$ – Asaf Karagila Feb 10 '12 at 15:51
  • 1
    $\begingroup$ @Asaf: yes, you hold the home and lock buttons for 7-10 seconds :) $\endgroup$ – The Chaz 2.0 Feb 10 '12 at 18:21
  • $\begingroup$ It also happened to me in Chrome (not Firefox) and Shift+F5 (which is apparently Fn+F5 on my HP laptop) works. I have no idea what the issue was. $\endgroup$ – anon Feb 10 '12 at 19:18
  • $\begingroup$ Would one of you (maybe @JM) make an answer? $\endgroup$ – Willie Wong Feb 10 '12 at 21:38
36
$\begingroup$

Per popular demand:

One of the first things you should do when MathJax is crapping out on you is to try a hard refresh, which is executed by holding your Shift key and then clicking the Refresh/Reload/whatever button in your favorite browser. Browsers usually cache stuff like images and JS bits to ease the task of loading a page. Since this cache is sometimes prone to getting crap on it one would sometimes want to do a hard refresh so that the browser is forced to pull stuff from the servers instead of from its cache.

The more drastic method is to do an actual cache clear (see your browser's help file for details) and restart. If all else fails, consider dropping a line here on meta, or for really severe problems, the MathJax team.

$\endgroup$
  • 1
    $\begingroup$ This doesn't solve it for me. I see the formula for a second but then the error jumps and the formula disappears. $\endgroup$ – bobsacameno Jun 5 at 12:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .