Yesterday, While browsing math.stackexchange.com I found a little popup, saying settings. I clicked it, and I was able to choose a TeX renderer for the forum. I chose another, and now all my TeX is messed up (not displaying correctly next to other text, the reserved space for the TeX is to small).

I have tried holding a piece of math with my finger, pinching it, holding it with one finger and tapping it with the other. Nothing worked, I couldn't get the popup to show again. Even on the non-mobile site I couldn't work it out.

Thanks in advance.

PS, I can't add a screenshot because I'm on my iPod, and I can't reproduce it on my desktop.

  • $\begingroup$ You can't take a screenshot from your iPod touch by pressing the "home" and "lock" buttons simultaneously? $\endgroup$ – The Chaz 2.0 Mar 14 '12 at 13:33
  • $\begingroup$ And how would you suggest I add it to my question? $\endgroup$ – Hidde Mar 14 '12 at 15:34
  • $\begingroup$ Imgur app --> upload to imgur --> embed link in question? $\endgroup$ – The Chaz 2.0 Mar 14 '12 at 15:51

To access the MathJax menu on the iTouch, you need to double-tap-and-hold (i.e., tap twice in quick succession and hold down the second tap) over some typeset mathematics. You might need to zoom in a bit to be able to click on the mathematics reliably. If you do this, you should see the MathJax menu after holding the second tap for a second or so. Then you can select the Math Settings and Renderer again to switch back to HTML-CSS.

I suspect you chose MathML, which isn't well supported on the iTouch. But you should have gotten a warning message where you had to confirm the change.

  • $\begingroup$ 1. I have tried that, no menu appears. If I press (and hold the second time) very quickly, the text is selected. I cannot get the menu to show. 2. Yes, I have seen that settings window when I changed my settings. I wanted to try them, because normally you can reverse any setting. ... Is there any JavaScript function i can call to show the menu? $\endgroup$ – Hidde Mar 14 '12 at 15:33
  • $\begingroup$ It is a little tricky at times to get it, and remember that it has to be over some actual mathematics. Did you try zooming in so that the math is larger? That often helps me. If not, the setting is stored in a cookie, so if you clear the cookies for this site, you should be back to normal. Otherwise, try the javascript command MathJax.HTML.Cookie.Set("menu",{}) which should clear the menu's cookie settings. One of those should work, I hope. $\endgroup$ – Davide Cervone Mar 14 '12 at 17:49
  • $\begingroup$ The JavaScript did the job, thanks for all the help. A ticket would be great, the menu was confusing, because I had never seen it before :) $\endgroup$ – Hidde Mar 14 '12 at 20:35

In fact the method Davide suggests allows to open the context menu given that on is in the HTML-CSS mode (which is standard). The problem is that once MathML is selected this menu does not open any more with a double-tap-and-hold (but instead the text gets selected).

The only way, I managed to get the prefered display style back was to delete all the Cookies. This can be done by opening Settings, then Safari, then delete all Cookies and Data.

Hope this helps.

  • $\begingroup$ OK, I see that you are right, double-tap-and-hold in MathML mode doesn't work, and you don't get the warning about making the switch. I'll start an issue tracker to fix the problem. The javascript command I gave does clear the issue for me (but you have to reload the page, which I forgot to mention). $\endgroup$ – Davide Cervone Mar 14 '12 at 18:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .