1
$\begingroup$

I use firefox (ubuntu) with enlarged fonts and have a problem with LaTeX formulas. They don't fit the space they a meant to occupy and overlay the ordinary text:

Font problem

Link to the answer on the screenshot.

It was ok several months ago, but then it seems that some update has happened. I can't remember exactly when the issue appeared first.

UPD1 Is there a workaround at least? It still happens and many tex comments are unreadable.

I don't know if that helps, the similar report for MathOverflow (look for comment by Charles Rezk Mar 24th 2012). I guess he also uses enlarged fonts.

UPD2 The very option that causes the behavior is "minimal font size". Both Chromium and Firefox exhibit it.

UPD3 I've opened an issue on MathJax's bug tracker, hope to find out what causes the problem.

$\endgroup$
  • $\begingroup$ It happens to me, but only one one of my computers; when I work on my small laptop, with a small display, the fonts default to something larger (I haven't tried to adjust that size). But on my regular UNIX machine (running Firefox) or my larger laptop which has larger screen and better resolution (running Firefox on Windows) it does not happen. $\endgroup$ – Arturo Magidin Jun 4 '12 at 15:24
  • $\begingroup$ A similar issue (concerning comments) is reported by joriki here. $\endgroup$ – t.b. Jun 5 '12 at 8:49
  • 3
    $\begingroup$ It happens to me after I edit a post. Refreshing the page always solves the problem for me. $\endgroup$ – user23211 Jun 5 '12 at 10:35
3
$\begingroup$

It turns out that setting the minimum font size messes up MathJax's ability to determine the em-size properly, and that means MathJax isn't reserving the proper amount of space for the mathematics in that case. I will look into it further, but for now I can offer the following GreaseMonkey script that will fix the size of the mathematics. It is set up to apply only to math.stackexchange.com and meta.math.stackexchange.com, but you could add other StackExchange sites if you want.

Note, however, that setting a minimum font size may mean that the sizing within the mathematics might not be right. For example, the superscripts and subscripts may not be sized correctly. MathJax does assume that when it sets the font size, the change actually does occur, and (for performance reasons) it doesn't remeasure the mathematics after doing so. That means that the clipping regions may not be correct if the font size is larger than expected, and that things may overlap vertically when they shouldn't.

Alternatively, you might consider changing to MathJax's SVG output rather than HTML-CSS output. The internal rendering will not be affected by your minimum font size setting, so the math will properly reduce the size of super- and subscripts, but the math will still be sized to match the surrounding font, so should be large enough for you to see.

I will look into improving the situation for a future release of MathJax, but hope this helps in the meantime.

$\endgroup$
  • $\begingroup$ Am I right that changing to MathJax's SVG is not something that is done on the user's (my) side? $\endgroup$ – Yrogirg Jun 9 '12 at 19:52
  • $\begingroup$ Anyway, the script works nice, as a workaround it is excellent, thanks. $\endgroup$ – Yrogirg Jun 9 '12 at 19:57
  • 2
    $\begingroup$ You can switch to SVG using the MathJax contextual menu. Right-click (or CTRL-click on a Mac) on any typeset equation and you will get a menu that has a "Math Settings" submenu. There, select "Math Renderer" and choose "SVG". That should do it. $\endgroup$ – Davide Cervone Jun 9 '12 at 21:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .