These days I frequently encounter MathJax problems as shown in the figure below. Even if I reload the page a few times, the issue remains. This seems to happen on and off. Am I the only one having such issues?


enter image description here


enter image description here


I took the image from Bill's answer here. I cleared the browser cache yesterday (before J.D pointed out) and it worked fine. However, I encountered the issue again now. This bug appears on Safari Mac OS X snow-leopard.

EDIT: (May 11th, 2012) I again encountered this problem for the question here. enter image description here

  • $\begingroup$ My experience is that putting $\color{red}{\textit{[Math Processing Error]}}$ usually solves my problem as well! $\endgroup$
    – Asaf Karagila Mod
    May 10, 2012 at 10:44
  • 1
    $\begingroup$ @Asaf Heh. Note that the errors arise only after introducing a phantom. Berekeley would have a field day with that. "But what are these phantoms? The reifications of evanescent expressions? And what are these same evanescent expressions? They are neither finite quantities, nor quantities infinitely small, nor yet nothing. May we not call them the ghosts of departed expressions?" No wonder MathJax blew up. $\endgroup$ May 10, 2012 at 13:47
  • $\begingroup$ @Bill, quite poetic. I'd imagine that these phantom expressions are like generic reals over some model of set theory. They are echoed by the reals in the ground, but these traces are nothing more than finite approximations. Never the reals themselves. $\endgroup$
    – Asaf Karagila Mod
    May 10, 2012 at 13:54
  • $\begingroup$ It is hard to tell what is going on if we cannot see the source that is being rendered. Just taking a screenshot of the $\color{red}{\textit{[Math Processing Error]}}$ doesn't give much to go on. $\endgroup$
    – robjohn Mod
    May 10, 2012 at 14:26
  • $\begingroup$ @Asaf Those are Berkeley's words, mod a few changes (fluxion -> phantom, etc). Compare Hankel's similar critique of Cauchy's definition of imaginary number: 'There must be something "which means nothing or "which is assigned a different value than it should naturally be" something that has "no sense"...coupled with another similar kind, producing something real... I do not think I'm exaggerating in calling this an unintelligible play on words, ill-becoming of mathematics, which is proud and rightly proud of the clarity and evidence of its concepts.' $\endgroup$ May 10, 2012 at 14:30
  • $\begingroup$ @robjohn It's from my answer here. Jokes aside, most likely, it has nothing to do with the particular $\LaTeX$ code but, rather, has to do with some external state. $\endgroup$ May 10, 2012 at 14:35
  • $\begingroup$ @Bill: Thanks for the reference. That answer renders fine for me. However, I had a similar problem recently where the problem was not buggy $\LaTeX$, but had I just posted an image, I think that Davide Cervone would have had a much harder time finding the problem. $\endgroup$
    – robjohn Mod
    May 10, 2012 at 15:22
  • $\begingroup$ Clearing browser cache might work.. $\endgroup$
    – user2468
    May 10, 2012 at 16:25
  • $\begingroup$ @J.D.Yes I did that and it works for sometime but then again it crops up after a day or two. $\endgroup$
    – user17762
    May 10, 2012 at 19:32
  • $\begingroup$ As with all bug reports, I suggest you include the various operation systems, architectures and browsers (with versions) which were involved in the process. $\endgroup$
    – Asaf Karagila Mod
    May 10, 2012 at 20:26
  • $\begingroup$ @AsafKaragila Yes. I have added the info now. $\endgroup$
    – user17762
    May 10, 2012 at 20:29
  • $\begingroup$ The screen shot of Bill's answer shows a mixture of untypeset math with "Math Processing Errors"; is that the case in your other examples as well (the screen shots don't show far enough down the page to see whether there are processing errors farther on). I'm wondering it isn't the same basic issue as Bill's link (a failure to properly recover after a restart for asynchronous file load). I am not able to reproduce the problem, though. Is anyone else seeing this? @Marvis, can you try disabling the STIX fonts in FontBook for a test? $\endgroup$ May 13, 2012 at 16:59
  • $\begingroup$ @DavideCervone I do not see the [Math Processing Errors] now. But I still see have untypeset math even now for the second question. $\endgroup$
    – user17762
    May 13, 2012 at 17:38
  • $\begingroup$ @marvis: Thanks for the info. I'm updating my system now to try to get 5.1.7 to experiment with (but it's 10.7 not 10.6). We'll see. In the meantime, do you have any extensions or other modifications to Safari? Did you try disabling the STIX fonts? $\endgroup$ May 13, 2012 at 17:49
  • $\begingroup$ @DavideCervone The problem occurs on 10.7 as well. The only extension I have on safari is Adblock. There are no other modifications to Safari. I tried disabling the STIX fonts but it does not help. Thanks for helping me out! $\endgroup$
    – user17762
    May 13, 2012 at 17:59


You must log in to answer this question.