8
$\begingroup$

NOTE: I am locking this question to make sure that people who have problems with the MathJax TeX rendering post their issue as a new question, rather than an answer here.

(This question was put up to deal with the immediate feedback when MathJax was first implemented.)


Per the most recent edit here, meta.math.SE and math.SE now have MathJax instead of the previous Google-Charts-based rendering. Feedback thus far?

$\endgroup$
  • 3
    $\begingroup$ The administrators should talk to Anton, who has successfully implemented mathjax with much fewer errors on the MO faketestsite. $\endgroup$ – 97832123 Aug 3 '10 at 12:50

11 Answers 11

7
$\begingroup$

The \binom thing can be solved by explicitly loading the AMSmath extension.

I also suggest adding the noUndefined extension, so mistyped formulae like

\Sum_{k=0}^{1024} k

will appear like

$$ \color{red}{\mathrm{\backslash Sum}}_{k=0}^{1024} k $$

instead of the current "Undefined control sequence \Sum". This way, at least the answer quoted by @Issac is readable before editing.

$\endgroup$
  • 4
    $\begingroup$ Thanks for the suggestions Kenny - I have enabled the AMSmath extension and noUndefined. $\endgroup$ – Geoff Dalgas Aug 3 '10 at 15:20
7
$\begingroup$
  • It looks much better.
  • It still doesn't work in the preview when you're editing an entryper this answer here on this question it now works in the preview.
  • It breaks on some things (e.g. $\binom{n}{r}$ $\binom{n}{r}$) (looks like the things I saw it breaking on are no longer a problem and with the noUndefined extension, it's much less of an issue anyway)
  • I don't think we have the double-click-to-see-source thing that MO has right-click to get a menu from which you can get the source
  • MathJax needs to be reapplied to the newly-reloaded comments after any of the actions that reload the comments (e.g. clicking "show more comments")
$\endgroup$
  • 5
    $\begingroup$ Occasionally it doesn't work for me the first time I load a page and I have to refresh, but that might be a client-side issue. $\endgroup$ – Qiaochu Yuan Aug 3 '10 at 2:40
  • $\begingroup$ $\sum$ let's see.... $\endgroup$ – 97832123 Aug 3 '10 at 2:48
  • 1
    $\begingroup$ Isaac, that's because it's \sum, not \Sum. LaTeX is case-sensitive. $\endgroup$ – 97832123 Aug 3 '10 at 2:49
  • $\begingroup$ Okay, I just picked on of the ones that produced the error on an answer here. \binom{n}{r} is another example. $\endgroup$ – Isaac Aug 3 '10 at 3:31
  • 1
    $\begingroup$ $n\choose r$ is still possible. $\endgroup$ – kennytm Aug 3 '10 at 8:25
  • $\begingroup$ Yes, using {n \choose r}, I know (although it now looks like \binom works). That point I was trying to make is that there was stuff that people had already put in place, expecting to work, that was not working. $\endgroup$ – Isaac Aug 3 '10 at 15:21
  • 1
    $\begingroup$ Clicking the "show more comments" link broke all the math in the comments. I thought this issue had already been fixed. $\endgroup$ – Larry Wang Aug 3 '10 at 19:51
  • $\begingroup$ The "show more comments" link breaking TeX was a problem on MO for a while, but Anton wrote a fix for it on MO that works for mathjax and jsMath. $\endgroup$ – 97832123 Aug 4 '10 at 16:42
6
$\begingroup$

You should no longer need a sandbox to test MathJax - just stop typing for around 4 seconds and watch the conversion occur in the preview.

$\endgroup$
  • 3
    $\begingroup$ Works for me. Thanks Geoff! Is it possible for the re-rendering pass to also cover expanded comments? $\endgroup$ – Larry Wang Aug 4 '10 at 4:38
  • 6
    $\begingroup$ You you reduce the waiting period to say 2 secs? $\endgroup$ – Mariano Suárez-Álvarez Aug 4 '10 at 6:20
2
$\begingroup$

It seems to be breaking all over the place. Fixing this is vital otherwise we'll have "broken-windows" all over the place

$\endgroup$
2
$\begingroup$

There's a bug when editing comments with formulae in it (note it is not really [status-completed])

$\endgroup$
1
$\begingroup$

That's very good news to hear. It looks nice, and is a worthwhile investment for the site.

Occasionally, my usual browser (Chrome on Linux) freezes, especially when I try to close a question, and the math does not actually display occasionally. I don't seem to have this problem with Firefox.

$\endgroup$
1
$\begingroup$

My usual browser (Internet Explorer 8) does not display math formulae (in LaTeX) of this site, unlike of a WordPress blog. I changed to Firefox, which displays them properly.

Addendum: Firefox 3.6.8 (Portuguese).

$\endgroup$
  • $\begingroup$ Please check if meta.math.stackexchange.com/questions/597/tex-broken-for-me/… solves the problem. $\endgroup$ – kennytm Aug 12 '10 at 13:22
  • $\begingroup$ @KennyTM: No, unfortunately. $\endgroup$ – Américo Tavares Aug 14 '10 at 15:56
  • $\begingroup$ For the first time using the same Internet Explorer I've written just now an answer that displayed correctely in the pre-view window. However in the Question and Answers view, it does not display properly. I do not find any explanation. $\endgroup$ – Américo Tavares Aug 15 '10 at 15:35
0
$\begingroup$

Looks good, definitely the way to go forward. No luck in Firefox 4.0 Beta 2 however (I get [Math Processing Error]) everywhere.

$\endgroup$
  • $\begingroup$ @Noldorin: As mentioned by Jeff in his answer to another meta question, beta browsers are not supported. $\endgroup$ – Larry Wang Aug 3 '10 at 20:31
  • 1
    $\begingroup$ @Kaestur: Would be nice to have an option to turn rendering off though, saying that. $\endgroup$ – Noldorin Aug 4 '10 at 16:16
  • $\begingroup$ @Noldorin: You could always just block the math-tex or MathJax scripts. Someone who knows more about Firefox can comment on the details. $\endgroup$ – Larry Wang Aug 4 '10 at 16:39
  • $\begingroup$ @Kaestur: This is true. Would be nice to have the option still, should be easy to implement. $\endgroup$ – Noldorin Aug 6 '10 at 8:24
  • $\begingroup$ Please check if meta.math.stackexchange.com/questions/597/tex-broken-for-me/… solves the problem. $\endgroup$ – kennytm Aug 12 '10 at 13:22
  • $\begingroup$ Seems to be working fine in Beta 3. Some layout issues though... $\endgroup$ – Noldorin Aug 19 '10 at 8:08
0
$\begingroup$

I'm always getting the math processing error in my usual browser, Firefox 3.0.19. It works all right with Chrome.

$\endgroup$
  • 1
    $\begingroup$ is there any particular reason you're using a browser two versions old? Firefox 3.5 and 3.6 were major releases with lots of big, big bugfixes. $\endgroup$ – Jeff Atwood Aug 8 '10 at 2:54
  • $\begingroup$ @Jeff: Thanks, updating firefox solved the problem! $\endgroup$ – AgCl Aug 8 '10 at 13:06
0
$\begingroup$

Works really slowly in Firefox 3.6.11 on MacOS X, perhaps for the reason mentioned here; it just takes ages until it starts rendering. In MO there's no delay but it's still a bit slow.

$\endgroup$
  • $\begingroup$ I'm locking this question because a lot of what's here is too old. Your answer here is important, but I fear that it will be lost in the noise here. Please repost this as a new question. $\endgroup$ – Isaac Oct 26 '10 at 21:11
0
$\begingroup$

I'd like to draw attention to the comment written by Kaestur Hakarl:

Works for me. Thanks Geoff! Is it possible for the re-rendering pass to also cover expanded comments?

In order to re-render comments, here is the appropriate documentation.

$\endgroup$
  • $\begingroup$ meta.math.stackexchange.com/questions/397/… $\endgroup$ – kennytm Oct 26 '10 at 19:51
  • $\begingroup$ I'm locking this question because a lot of what's here is too old. Your answer here is important, but I fear that it will be lost in the noise here. Please repost this as a new question. $\endgroup$ – Isaac Oct 26 '10 at 21:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .