1
$\begingroup$

It appears that certain questions are not accessible from the main page, e.g. this question: Re-writing sign basis. I finally got it over the user's page, but the links on the main page or the tag page seem not to be active, see here.

This already happened once to me, after a while the link was working. Why is that?

EDIT

The strange behaviour is still present. Now from a different computer, but here's something interesting:

When I mark the question title, I get the following: enter image description here

Does this give anyone a hint?

$\endgroup$
  • $\begingroup$ It's a question about quantum mechanics, so I suppose the question was in superposition and you collapsed the wave function at the wrong time... :-) $\endgroup$ – Asaf Karagila Jul 23 '12 at 21:54
  • 1
    $\begingroup$ Also, it works fine for me from the tag page and the front page. Browser/OS/favourite mathematical constant? $\endgroup$ – Asaf Karagila Jul 23 '12 at 21:54
  • $\begingroup$ It's true: the other one was also dealing with QM. No wait ... General Relativity...M.SE doesn't play dice, right? I'm using WindowsXP/Firefox/primes $\endgroup$ – draks ... Jul 23 '12 at 21:56
  • 1
    $\begingroup$ You should probably add that to the post, preferably add the exact version of Firefox too (and architecture, although I suppose that if it's XP then 32bit). $\endgroup$ – Asaf Karagila Jul 23 '12 at 21:59
  • 1
    $\begingroup$ True: 32bit WindowsXP, Firefox 14.0.1, do we need more. I just rechecked: it's still in a superposition... $\endgroup$ – draks ... Jul 23 '12 at 22:00
  • $\begingroup$ What do you mean by "superposition"? What do you see when you click the link? (FWIW, it works for me.) Have you tried clearing history and/or cache? $\endgroup$ – Willie Wong Jul 23 '12 at 22:01
  • $\begingroup$ @WillieWong see Asaf's first comment. I can't click it. It seems like the link to the question doesn't exist in my reality. $\endgroup$ – draks ... Jul 23 '12 at 22:03
  • $\begingroup$ @WillieWong I cleared the cache, without effect... I can click on the main page now, but neither on recent questions, nor on newest 'QM'... $\endgroup$ – draks ... Jul 23 '12 at 22:05
  • $\begingroup$ What do you mean by "can't click it"? Is something physically preventing you from depressing the mouse button? Or do you mean that you can click, just that nothing appears to happen when you do? $\endgroup$ – Henning Makholm Jul 24 '12 at 1:09
  • $\begingroup$ @HenningMakholm I mean, there is nothing to click on. The link is missing. And it still doesn't work from the link "newest QM" page. But I found something interesting ... $\endgroup$ – draks ... Jul 24 '12 at 6:46
  • $\begingroup$ If instead of the newest QM page, you sort by votes on QM, is the problem still there? $\endgroup$ – Willie Wong Jul 24 '12 at 8:05
  • $\begingroup$ @WillieWong yes the problem and its strange marking behaviour is still there. Could it be something in the body of the post? Maybe if we edit it, the problem could disappear, but then we loose the object of study... $\endgroup$ – draks ... Jul 24 '12 at 8:10
  • $\begingroup$ @WillieWong and think this change in behaviour after editing happened somewhen in the past to this question. When you look at the first revision, you'll recognize some special characters. I remember (in fact I tracked it) that I had the some problem on the main site, but then I edited that question and the problem vanished! What do you think? $\endgroup$ – draks ... Jul 24 '12 at 8:18
  • 1
    $\begingroup$ @draks: I just edited the question to remove the unicode characters and replace by mathjax equivalents. Please wait a few minutes to see if it changes anything. $\endgroup$ – Willie Wong Jul 24 '12 at 8:30
  • $\begingroup$ @WillieWong It worked. I'll post a new screenshot. $\endgroup$ – draks ... Jul 24 '12 at 8:39
2
$\begingroup$

The underlying reason seems to be roughly the same as described in this answer, except that in the present case the culprit character turned out to be U+27E9 MATHEMATICAL RIGHT ANGLE BRACKET, rather than an invisible one.

It seems that Firefox has some trouble with one of the fonts it uses for mathematical Unicode characters.

$\endgroup$
  • $\begingroup$ Thx. So we just wait for the next Firefox? And use Mathjax of course... $\endgroup$ – draks ... Aug 6 '12 at 6:06
0
$\begingroup$

As discussed in the comments, replacing the unicode characters with mathjax solved the all problems. enter image description here Thanks for your support!

$\endgroup$
  • $\begingroup$ There is, however, still the question of why those characters break the display for your set-up, and not for many other people. I suggest leaving the question open for a while and see if we get some attention from the Stack team. $\endgroup$ – Willie Wong Jul 24 '12 at 8:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .