9
$\begingroup$

The rendering of math formulas seems very broken on my iphone. On the main page, math in questions disappears during loading, and sometimes "math processing error" replaces it. On question pages, either the math is displayed in TeX format (which is fine) or "math processing error" appears. I just spent a couple minutes loading and reloading and I never saw math render correctly. When the "math processing error" message appears, the content is unreadable.

For comparison, the math on question pages renders fine on my iphone on mathoverflow.

$\endgroup$
  • $\begingroup$ Using Safari's Debug Console on my iPad reveals the following (single) error: "JavaScript Error on Line 1: undefined. TypeError: Result of expression 'c.FONTDATA.FONTS.MathJax_Main[8212][5]' [undefined] is not an object." $\endgroup$ – Blue Aug 10 '10 at 1:59
  • $\begingroup$ I am experiencing the same issue. I was going to post this :) $\endgroup$ – BBischof Aug 10 '10 at 2:47
  • $\begingroup$ It's working on my iPad now ... mostly. No "math processing error"s , but variables aren't in italics, and there are some sizing issues (tiny integral and summation signs in displayed formulas, large type in "choose" brackets). For instance: math.stackexchange.com/questions/2628/… . MathOverflow's system tends to render better. Still, just about anything beats those error boxes, so I appreciate the fix. $\endgroup$ – Blue Aug 19 '10 at 13:15
1
$\begingroup$

Reproduced on iPhone OS 3.1 to 4.0. Interestingly, the samples from http://www.mathjax.org all work. Probably because we are still using 1.0 beta2, while the official 1.0 has been released 6 days ago?

iPhone OS (still) doesn't support OTF, and MathJax reverts to rendering with images. But the folder that containing the images (https://math.stackexchange.com/content/js/third-party/MathJax/fonts/HTML-CSS/TeX/png) does not exist, so it will fail to show anything.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .