5
$\begingroup$

I keep getting [math processing error] in bright red, everywhere on the site all the time and, while it has been amusing trying to read the raw tex code before mathjax ruins it for me, this is starting to grate.

Mathjax was working fine for me until two days ago, at which point it flat out broke in the way described. Since then, have tried a few refreshes and opening and closing the browser but to no avail. Am running firefox if that helps.

Has anyone had similar difficulties? Is there something obvious for me to do?

$\endgroup$
  • $\begingroup$ We also have other reports of Math Processing Error. Have you tried upgrading Firefox to 3.5.x? $\endgroup$ – kennytm Aug 12 '10 at 10:01
  • $\begingroup$ I think I have. I updated about a month ago to the latest version. I didn't post on the linked thread/ consider this (possibly) to be a new bug because mathjax was working fine for me until two days ago. Have edited the question because I forgot to add the time frame. $\endgroup$ – Tom Boardman Aug 12 '10 at 10:16
  • $\begingroup$ @Tom: Before the Math Processing Error appears, there should be a message in the gray status bar appearing on the lower-left corner. Can you see the error from there (just a rough description is fine)? Also, if you have AdBlock or something like these, try to turn them off. $\endgroup$ – kennytm Aug 12 '10 at 10:19
  • 1
    $\begingroup$ Okay, so I might be getting this a little wrong but the two error-sounding bits I am getting are something like File failed to load: math.stackexchange.com/js/third-party/mathjax/jax/html-css/… and File failed to load: math.stackexchange.com/js/third-party/mathjax/jax/html-css/… $\endgroup$ – Tom Boardman Aug 12 '10 at 10:28
  • $\begingroup$ And, at the risk of soliciting spam, I am not running any pop up blockers other than the natural widgets that come in firefox. $\endgroup$ – Tom Boardman Aug 12 '10 at 10:30
  • 2
    $\begingroup$ Check Tools -> Error console to see if there's any Javascript Errors. Also, try to Shift+Click refresh to force the browser to clear the cache. $\endgroup$ – kennytm Aug 12 '10 at 10:46
  • 2
    $\begingroup$ @KennyTM- you sir, are an internet genius! Clearing the cache worked like a charm. [status- completed] tag time methinks! $\endgroup$ – Tom Boardman Aug 12 '10 at 11:44
5
$\begingroup$

(Answered for future reference)

It looks like the browser is caching a wrong version of MathJax. Try to clear the browser cache by holding Shift and click Refresh.

$\endgroup$
  • $\begingroup$ Or Ctrl+F5..... $\endgroup$ – igor Dec 6 '10 at 8:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .