2
$\begingroup$

I can't get any of the tex on any question anywhere to render at all. I'm on windows7 and I've tried FireFox 15, IE9, Chrome, etc. all appear the same: just the original markup is displayed.

I've tried updating, flash, java, disabling all addons, safe-mode, etc.

I can trouble-shoot the problem further, but what underlying technologies are responsible for the actual parsing and rendering of this stuff? I can't really find the root cause if I don't know that part. All I know is it's definitely client-side at some level.

$\endgroup$
  • 1
    $\begingroup$ Do formulas render on MathJax page? $\endgroup$ – user31373 Sep 24 '12 at 22:50
  • 1
    $\begingroup$ Have you checked the error console in your browsers to see if there are any messages there about MathJax? $\endgroup$ – Davide Cervone Sep 24 '12 at 22:58
  • 1
    $\begingroup$ Much of MathJax is based on Javascript, do you have that enabled? Is this lack of rendering a recent event (as in, previously you had it working, and now it broke) or has it never worked for you? $\endgroup$ – Willie Wong Sep 25 '12 at 7:38
  • $\begingroup$ This is currently happening to me (While just answering a problem, it stopped rendering). Those formulas render in my MathJax page. What can I do to resolve this? Thanks a lot! $\endgroup$ – Poypoyan Dec 13 '15 at 13:07
1
$\begingroup$

For other people who come across this question: MathJax fails to load if the site is being viewed through HTTPS. Make sure the site is being viewed through regular HTTP (should be http:// or the URL directly, not https://.

Note that HTTPS Everywhere forces HTTPS - if that add-on is enabled, then disable HTTPS Everywhere for just this site, and then reload the page without HTTPS.

$\endgroup$
  • $\begingroup$ I think that a year and a half ago, that wasn't the problem. $\endgroup$ – Asaf Karagila Jan 29 '14 at 22:34
  • $\begingroup$ @AsafKaragila: How come? No https support 1.5yrs ago? $\endgroup$ – Claudiu Jan 29 '14 at 22:42
  • $\begingroup$ Fairly sure it's a recent thing. At least outside SO itself. $\endgroup$ – Asaf Karagila Jan 29 '14 at 22:44
  • $\begingroup$ @AsafKaragila: Hmm well this question was posted 12/21/2011 saying "So it looks like Stack Exchange now supports HTTPS (to some extent).". Granted, it's still not the default unless you have HTTPS Everywhere or soemthing - if it were then my issue would not have come up $\endgroup$ – Claudiu Jan 29 '14 at 22:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .