1
$\begingroup$

What's wrong with the software today? When I'm typing or editing an answer, the $\TeX$ doesn't get rendered and all sorts of strange messages are splattered across the screen. After I've saved the answer, I see a similar thing until I hit the "reload" button.

$\endgroup$
2
$\begingroup$

I solved the mystery!

There is a deleted answer which caused this. This is why users with reputation below 10,000 did not have the bug anymore. I have edited this answer to remove the "malicious" code. All should be fixed.


I can confirm the bug report, I got this on this answer. Refreshing didn't help, nor did a hard refresh (Ctrl+F5).

The screenshot from a minute ago or so.

LaTeX bug screenshot

Firefox 16.0.1; Arch Linux (kernel 3.5.6-1 x86-64).

$\endgroup$
  • $\begingroup$ This is the same sort of thing that I saw. $\endgroup$ – Michael Hardy Oct 12 '12 at 23:42
  • $\begingroup$ Yes. @Michael. I figured that much, I added a screenshot because it's usually a good idea when reporting such bugs; also I wanted to confirm the bug. $\endgroup$ – Asaf Karagila Oct 12 '12 at 23:59
  • $\begingroup$ The red macros are ones that MathJax doesn't understand (it doesn't implement the box registers and things like the \ht and \dimen registers). Why they are in the problem, I don't know; but they aren't there today, and I don't see any edits for that answer. It looks like some complicated TeX code was used originally, and MathJax doesn't know how to handle it. $\endgroup$ – Davide Cervone Oct 14 '12 at 1:44
  • $\begingroup$ @Davide: These things do not appear in the original post. $\endgroup$ – Asaf Karagila Oct 14 '12 at 7:56
  • $\begingroup$ @AsafKaragila, I understand that. It looks like something has added code around the square roots to try to give the contents of the square root more depth (not sure why). I'm wondering of someone in another answer or comment redefined \sqrt to do that, and that definition then applied to the rest of the page. Since the page is now showing properly, I assume who ever did that removed it one he or she saw it was a problem. But Michael and you saw the page while it was still active. I assume you don't see it now? $\endgroup$ – Davide Cervone Oct 14 '12 at 10:05
  • $\begingroup$ @Davide: I still see it wrong. Is there any way to trace where this code is added? (I have some experience in debugging, so if you want to give me some general idea where to look for it, I might be able to find it). $\endgroup$ – Asaf Karagila Oct 14 '12 at 11:56
  • $\begingroup$ @AsafKaragila, sounds like you did find it. Good detective work. That explains why I didn't see the issue when I look at it (my tiny prestige doesn't allow me to see deleted items). $\endgroup$ – Davide Cervone Oct 15 '12 at 14:57
  • $\begingroup$ @Davide: Yes. The fact you said it works fine got me thinking, I opened it with Chromium, and it was logged out and worked fine; then it found the cookie jar and told me I am logged in. I refreshed and it failed again, so I realized it must be something deleted. I edited that to a message that one should not only delete, but also edit away the bad code -- and never experiment on the main site. $\endgroup$ – Asaf Karagila Oct 15 '12 at 14:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .