1
$\begingroup$

I have been trying to accept the answer for this question for 4 hours now.
I keep receiving the message 'you can accept the answer in 5 minutes'.
Is this something I should worry about?
Or just trying later on might works?

$\endgroup$
  • $\begingroup$ tried refreshing the page? $\endgroup$ – Willie Wong Oct 15 '12 at 6:56
  • $\begingroup$ @WillieWong Yes, and also restarting my browser. I have the same issue for this question too. For both of this question, I somehow received the message 'your vote has been locked'. $\endgroup$ – user14108 Oct 15 '12 at 10:21
  • $\begingroup$ Can you detail what action lead to "your vote has been locked" coming up? In particular, are you clicking on the faded check mark or are you clicking on the arrow? $\endgroup$ – Willie Wong Oct 15 '12 at 10:58
  • $\begingroup$ @WillieWong I wanted to click on the check mark, but inadvertently down vote the answer. Then I up vote the answer and get the 'locked vote' message. After this, I always receive 'you can accept in 5 min'. This happened for both post. The reason I inadvertently down vote, is that my Mathjax finish rendering just before I click, lowering all the lines of the page. $\endgroup$ – user14108 Oct 15 '12 at 12:02
  • $\begingroup$ I just made some small edits to both of the answers you linked to. The vote-lock should be voided now. You should be able to go ahead and up-vote and accept the answer. If you still have a problem, drop a note here and I'll try to get a StackExchange team member to help you out with it. $\endgroup$ – Willie Wong Oct 16 '12 at 7:18
  • $\begingroup$ @WillieWong It worked, but I don't know if it is because of your edit. Right after your edit, I tried, then I again received the 'wait 5 min' message. Then I did a 'clear all cookie and data' in my browser, relog into mathSE, then I was able to accept the answer. Thank you very much for your help. $\endgroup$ – user14108 Oct 16 '12 at 10:22
  • $\begingroup$ Glad to know it somehow got resolved. This sounds like one of those mysterious bugs that depends on a confluence of circumstances. It'd be difficult to find a definitive explanation. I encourage you to post an answer yourself to this question and accept it to indicate that the bug has, at least temporarily, been dealt with. $\endgroup$ – Willie Wong Oct 16 '12 at 10:25
4
$\begingroup$

Digging through the traffic logs, I see exactly two attempts to accept that answer coming from your IPs.

The first, at 2012-10-14 10:53:06.573, would have fallen in the "you must wait 5 minutes to accept" window and been correctly rejected.

The second, at 2012-10-16 10:17:51.477, is the one that actually accepted the answer.

Since no other votes got to our logs, I'm forced to guess a little bit about what happened here but I've got an idea...

I noticed that you were trying to vote from an iOS 6 device, and the symptoms match a bad browser cache or proxy (whenever you're voting your sending a POST request, which should never be cached; but if it were, the "wait 5 minutes" message would always be returned and the request would never be sent). It just so happens that there is a known bug in Safari on iOS 6 related to POST and caching, and I strongly suspect that you're falling victim to it (that clearing Safari's cache ultimately fixed it is another point of evidence).

For now all I can advise is that you don't vote using an iOS 6 device, and hope Apple patches this quickly (I'm a little shocked this hasn't already been patched honestly, that's a massive bug).

$\endgroup$
  • 1
    $\begingroup$ Very high detective ability. I effectively used an IOS6 device. Thanks for digging on this issue. $\endgroup$ – user14108 Oct 16 '12 at 21:09
1
$\begingroup$

With all the tentatives Willie and I did, a possible resolution might be the following.

  1. Do a 'Clear all data and cookie' in your browser. Restart your browser. Relog into mathSE and try to accept the question.

  2. If (1) fails, ask someone who can to make a small edit to the answer, so that the vote lock will be void. Then try (1) again.

How this bug appeared:
Up vote the answer, downvote it right, then up vote right away. Your vote should be locked now.
Try to accept the answer, you should received 'you can only acceot in 5 minutes'.

$\endgroup$

You must log in to answer this question.