1
$\begingroup$

I am not sure what happened (perhaps an upgrade in FireFox) but the commenting system completely stopped working in FireFox.

The FireFox version is: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729)

The things that don't work

  • Add Comment: Clicking on it does not bring up the textbox to add a comment.
  • Show more comments: Clicking on it does not expand.
  • Cannot upvote comments. Hovering near the comment does not show the clickable upvote comment.

I am also unable to upvote/downvote answers/questions.

I haven't tried posting an answer yet, so don't know if that is not working too (my guess is it will work fine, as this looks like a Javascript issue).

Here is an error shown by the Javascript error console:

Error: vote is not defined
Source File: http://math.stackexchange.com/questions/5617/party-planning-problem
Line: 46

And this is a warning:

Warning: The 'charCode' property of a keyup event should not be used. The value is meaningless.
Source File: http://math.stackexchange.com/questions/5617/party-planning-problem
Line: 0

A refresh does not help.

I didn't try deleting the cached js files, yet.

Strangely enough, on a different computer (different OS version altogether) with the same firefox version, it works: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

I suppose it is something local...

$\endgroup$
  • $\begingroup$ Have you tried doing a shift-reload, which does some cache-clearing without having to dig around in the cache or clear it entirely? $\endgroup$ – Isaac Sep 28 '10 at 16:06
  • $\begingroup$ I tried shift+reload. Does not seem to work. $\endgroup$ – Aryabhata Sep 28 '10 at 16:12
  • 1
    $\begingroup$ @Moron: Can you load sstatic.net/js/question.js?v=e24dbefef57d ? $\endgroup$ – kennytm Sep 28 '10 at 16:41
  • $\begingroup$ @Kenny: I will let you know in about 8-9 hours. I am away from that computer currently. $\endgroup$ – Aryabhata Sep 28 '10 at 16:54
  • 2
    $\begingroup$ @Kenny: No, I can't load that page using the computer that is giving me problems: Content Encoding Error. "The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression." $\endgroup$ – Aryabhata Sep 29 '10 at 1:35
  • $\begingroup$ @Moron: Try clearing the cache. $\endgroup$ – kennytm Sep 29 '10 at 13:58
  • $\begingroup$ @Kenny: Apparently I didn't have to! It works now. Perhaps if you will care to add your comment as an answer, then I can tick that. I suppose this is not just local to me, based on the upvotes to my comment about not being able to load it. $\endgroup$ – Aryabhata Sep 29 '10 at 14:15
4
$\begingroup$

Sometimes the browser will cache an invalid Javascript / CSS file. You could try to completely clear the disk cache to force it download the correct version.

For Firefox, see http://kb.mozillazine.org/Clearing_the_cache.

$\endgroup$
0
$\begingroup$

I also had unusual experience with comments today:

Edits to a comment on meta, within the time limit, were denied with the error "you can only edit comments every 5 seconds" (or whatever the allowed frequency), although the time between posting and editing was more than that, and I experimented with longer delays but was denied in all cases.

This is in Firefox 3.6.9 on Mac OS X.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .