are people facing problem of not loading latex symbols in MSE? I have high speed internet connection but I am facing this problem from yesterday,any suggestion?It says "math processing error" if my connection is low speed but this is not the case, I am just watching all latex symbols instead of compiled complete picture.

| |

Try clearing your cache and restarting your browser (restarting is an important step). It may be that you have a mixture of v2.1 and v2.2 files in your cache. The CDN edge nodes should have been updated by now, so it is probably a caching problem on your end.

| |
  • $\begingroup$ I did that again and again infact I cleared total history emptied cache cookies all restart laptop all all but stil not solved. $\endgroup$ – Marso May 20 '13 at 6:41
  • $\begingroup$ waiting for gravatar.com $\endgroup$ – Marso May 20 '13 at 8:45
  • $\begingroup$ What is your browser and OS (and their version numbers)? $\endgroup$ – Davide Cervone May 20 '13 at 22:30
  • $\begingroup$ firefox,google chrome(chromium browser), ubuntu 12.04 $\endgroup$ – Marso May 20 '13 at 22:56
  • $\begingroup$ We have not received any other reports of people having problems with v2.2 that have not bee solved by clearing the cache and restarting the browser. So I'm not sure what to suggest for you. Are there any error messages in the javascript console? $\endgroup$ – Davide Cervone May 20 '13 at 23:59
  • $\begingroup$ what is javascript console $\endgroup$ – Marso May 21 '13 at 4:59
  • $\begingroup$ It is where javascript errors are reported, and where you can enter javascript commands by hand for execution. In Chrome, for example, use the View->Developer->Developer Tools menu item, and select the Console pane using the tabs at the top of the tools panel. $\endgroup$ – Davide Cervone May 21 '13 at 10:27
  • $\begingroup$ Uncaught TypeError: Cannot read property 'strings' of undefined" when I cliked on javascript console $\endgroup$ – Marso May 21 '13 at 11:17
  • $\begingroup$ I found javascript console developer tools etc in crome what i have to do? $\endgroup$ – Marso May 21 '13 at 11:18
  • $\begingroup$ That looks like a message out of the localization system. Have you tried to change the language using MathJax's contextual menu? Try removing the cookies for math.stackexchange.com and meta.math.stakexchange.com and see if that helps. $\endgroup$ – Davide Cervone May 21 '13 at 13:02
  • $\begingroup$ Have you tried to change the language using MathJax's contextual menu? how to do that? cookies cleared but did not help that $\endgroup$ – Marso May 21 '13 at 15:09
  • $\begingroup$ I have posted as an answer the prsent console output $\endgroup$ – Marso May 21 '13 at 15:10

The timing suggests that the problem was related to the release of MathJax 2.2:

During the time that the files are making their way out to the CDN’s servers, there may be a mixture of files in a browser cache, and so users may need to clear their cache and restart their browser in order to get a consistent version of the files.

| |

Uncaught TypeError: Cannot read property 'strings' of undefined TeX-AMS_HTML.js:43 a.CreateLocaleMenu TeX-AMS_HTML.js:43 a.showRenderer.a.cookie.showRenderer.p.showRenderer TeX-AMS_HTML.js:43 CALLBACK.execute MathJax.js:29 (anonymous function) MathJax.Object.Subclass.Execute MathJax.js:29 QUEUE.Subclass.ExecuteHooks MathJax.js:29 CALLBACK.execute MathJax.js:29 (anonymous function) MathJax.Object.Subclass.Execute MathJax.js:29 QUEUE.Subclass.Post MathJax.js:29 CALLBACK.execute MathJax.js:29 (anonymous function) BASE.Object.Subclass.Process MathJax.js:29 BASE.Object.Subclass.call MathJax.js:29 WAITEXECUTE MathJax.js:29 (anonymous function) MathJax.Object.Subclass.Execute MathJax.js:29 a.Ajax.loadComplete MathJax.js:29 (anonymous function) TeX-AMS_HTML.js:59

| |
  • $\begingroup$ I'm sorry, this really looks like you have a mix of v2.1 and v2.2 files, which suggests a caching problem (or a problem with the CDN edge node nearest you, though that seems less likely). Can you type MathJax.version in the console window and see what version you are seeing? It looks like you might have a v2.1 copy of MathJax.js but a v2.2 copy of MathMenu.js. That's the only thing I can think of that would cause this error (CreateLocaleMenu() is trying to look up MathJax.Localization.strings, which is defined in MathJax.js v2.2 but not v2.1) $\endgroup$ – Davide Cervone May 21 '13 at 22:34
  • $\begingroup$ yes it says version 2.1 $\endgroup$ – Marso May 21 '13 at 22:54
  • $\begingroup$ what should i do now? $\endgroup$ – Marso May 21 '13 at 22:54
  • $\begingroup$ Are you SURE you cleared your cache successfully? That would be the first thing I'd check. Then if that doesn't help, can you try another browser that you've not used before (or not in a while) and see what happens with that? I don't know the details of the CDN, but I'll talk to some others and see how we can find out about the edge node you are using (if that can be done) and whether we can figure anything out from that end. $\endgroup$ – Davide Cervone May 21 '13 at 23:20
  • $\begingroup$ Another possibility: are you using a proxy server? It may be that that server has a cache that has a mixture of versions. Perhaps you can try without it temporarily? $\endgroup$ – Davide Cervone May 21 '13 at 23:24
  • $\begingroup$ Another possibility: do you have any extensions that might be loading another copy of MathJax? Are the equations on www.mathjax.org shown properly for you? $\endgroup$ – Davide Cervone May 22 '13 at 0:35
  • $\begingroup$ with out doing anything right now just rightnow MSE symbols are working fine :D let see when again I face the problem $\endgroup$ – Marso May 22 '13 at 4:39
  • $\begingroup$ OK, glad to har it is working for you know. Can you use the MathJax contextual menu's About MathJax item to confirm that you are using MathJax v2.2? If so, either your cache expired and was refreshed from the CDN with v2.2, or the CDN edge node finally caught up. In either case, I'm glad you are able to proceed now. $\endgroup$ – Davide Cervone May 22 '13 at 10:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .