Questions tagged [bug]

Indicates a reproducible problem on the site that you believe is due to a mistake, malfunction, or programming error.

Filter by
Sorted by
Tagged with
59 votes
5 answers
3k views

The scope of \newcommand is the entire page

LaTeX on this site supports \newcommand and \renewcommand. This is very nice, but I noticed that the scope of these definitions ...
Nate Eldredge's user avatar
8 votes
2 answers
425 views

Why does @someone sometimes disappear from comments?

I find the following occurring bug weird. When I post a comment I start with @someone. But for some reason this does not always get into the text. I get no error message but it is not there. In ...
mick's user avatar
  • 16k
17 votes
1 answer
684 views

Too long LaTex formulae not shown in comments?

If you try to show this formula in comments, it fails. $$M:\left[\begin{array}{cc}x&y\end{array}\right]\mapsto\left[\begin{array}{ccc}x&y&1\end{array}\right]M=\left[\begin{array}{ccc}u&...
hhh's user avatar
  • 5,479
4 votes
2 answers
402 views

Spurious space within number

In this comment, the penultimate number in the list, $59930$, is displayed (in Firefox $11.0$) with a spurious space between the two $9$s. I made sure I hadn't inadvertently pasted any invisible ...
joriki's user avatar
  • 238k
34 votes
4 answers
2k views

The return key in comments

I have noticed recently that when composing comments, pressing the return key submits the comment as is. This behaviour differs from that when composing replies. I am using Firefox. As I frequently ...
Robin Chapman's user avatar
8 votes
1 answer
581 views

MathJax not displayed in comments

In the Android App, the MathJax is not displayed correctly in comments to answers. I assume this also applies to comments the question, but I have not verified that.
Christopher Rucinski's user avatar
39 votes
3 answers
1k views

Searching for accented characters is too strict

A search for "lindelof" and a search for "lindelöf" produce different results. In some sense the results are correct, since the first search finds only those posts that mention "lindelof" and the ...
MJD's user avatar
  • 65.4k
15 votes
1 answer
3k views

How to put math equations in a "spoiler" block?

I wanted to do something like >! \begin{align} >! x &= 42 >! \end{align} (Unfortunately even this code block is badly formated! Why is it ...
Petr's user avatar
  • 2,307
13 votes
0 answers
2k views

MathJax preview broken when equations contain `\label`s

One can use \tag, \label, \ref and \eqref the usual way ...
Tobias Kienzler's user avatar
11 votes
0 answers
159 views

Hot network questions incorrectly use MathJax [duplicate]

This is the converse of http://meta.math.stackexchange.com/questions/10570/title-formatting-of-latex-in-stackexchange-hot-questions-list. I noticed that when on Math.SE, MathJax can screw up the ...
Nate Eldredge's user avatar
11 votes
4 answers
956 views

Showstopper bug: MSE+MathJax unusable for 6 months with Chrome

For roughly six months or so, since around the latest MathJax deployment, the site has been highly unstable using recent Chrome versions (17-22) on Windows 7. I see guaranteed page freezes composing ...
Bill Dubuque's user avatar
8 votes
3 answers
306 views

Comment error while posting comments [duplicate]

When I want to give a comment on a question/answer to a particular user, say David, i generally type @David: This is blah,blah... But recently that is the past 2 days, I am observing that the "@" ...
user avatar
4 votes
1 answer
123 views

LaTeX in tag wikis

LaTeX renders fine when you go to the tag-info page, for example, abelian-groups. However, when you try to add the abelian-groups tag to your post it doesn't render in the pop-up. This is messy. Is ...
user1729's user avatar
  • 31.1k
3 votes
3 answers
660 views

Matrices not rendered correctly

See e.g. here. I tried both \begin{pmatrix}... and \begin{array}{cc}.... edit Reading the answers, the problem turns out to be ...
Tobias Kienzler's user avatar
30 votes
2 answers
428 views

Try to comment: Fail review audit

I know the review audits aren't without their flaws, but with this review: https://math.stackexchange.com/review/first-posts/109542 it should be clear that something is not right. As usual, the vote ...
Lord_Farin's user avatar
  • 17.8k
14 votes
3 answers
406 views

TeX formatting in other comments in the same post is lost when the comment list is updated

If there's any TeX formatting in comments of a post, after you add a comment to that post, or click "add / show n more comments", all formulae are reverted to $...$....
kennytm's user avatar
  • 7,495
14 votes
3 answers
7k views

Links / URLs containing special characters are not recognized by markdown

In this answer, I linked to some page within the Wolfram alpha site, and the links did not appear. For example, I will try to link the last word in this sentence. Here is the URL I was trying to link ...
David E Speyer's user avatar
12 votes
1 answer
589 views

I can't search on ^

I was trying to search for duplicates for this question: How to define the $0^0$? But it's very hard to do this, as the search engine seem to ignore the ^ symbol. Searching for "0^0" or "0 0" give ...
Kasper's user avatar
  • 13.5k
11 votes
1 answer
363 views

old \def definitions linger

It's possible to use \def, and it usually works. However, there's a problem in that the definitions stick around and there seems to be no way to get rid of them ...
joriki's user avatar
  • 238k
10 votes
0 answers
198 views

Editing now completely blocked while an edit is pending

In tags should be editable despite pending edit to text and vice versa, I noted that it was bad that one was being forced to review edits in order to be able to edit posts with a pending edit; but at ...
joriki's user avatar
  • 238k
9 votes
2 answers
702 views

MathJax not rendering in comments and post preview

The problem with comments seems to have resolved itself. If we used the "show x more comments" link, the MathJax would become unrendered in all comments on that page. However, this is either ...
robjohn's user avatar
  • 346k
8 votes
2 answers
302 views

MathJax menu obliterates link menu when the entire link is LaTeX

When the title of a link is entirely in LaTeX, e.g. a question named on the front page such as this one, then there is no way to get the link menu (e.g. to copy the url) since the MathJaX menu applies ...
Bill Dubuque's user avatar
7 votes
2 answers
212 views

Why can I not use my additional 10 votes on just questions.

I voted 30 times on answers and questions, before reaching 30 votes. I cannot reach 40 votes. I beg the title.
superAnnoyingUser's user avatar
7 votes
0 answers
594 views

Why does not $a < b$ render here?

On the MathJax demo page, entering a &lt; b results in $a<b$. This is consistent with MathJax documentation. On Mathematics.SE the behavior is different: $a ...
user127096's user avatar
  • 9,693
17 votes
3 answers
321 views

Editing a comment containing formulae will mangle the formulae

Somewhat of a duplicate of http://meta.math.stackexchange.com/questions/419/editing-a-question-containing-formulae-will-remove-the-formulae. I reposted the question because the previous one - had a ...
Larry Wang's user avatar
  • 9,513
12 votes
3 answers
2k views

Broken imgur-links

Is there any plan to take care of broken imgur image-links? They look like this: (This picture is taken from Bill Dubuque's answer here which was posted not even two months ago—look at the ...
t.b.'s user avatar
  • 78.2k
12 votes
1 answer
438 views

Old usernames and names of deleted users in CW-mode

I noticed this several times already: In CW-questions e.g. here (active user) or answers e.g. here (deleted user) not the current (or anonymized) user name but rather the one that was active at the ...
t.b.'s user avatar
  • 78.2k
12 votes
3 answers
1k views

Chrome doesn't display some symbols

Specifically, I cannot see any \mathcal symbol. The \mathbb symbols are also in a very weired font. Here are some examples and what I see on my browser: $$\mathcal{A},\mathcal{B},\mathcal{D},\mathcal{...
RS.'s user avatar
  • 117
11 votes
4 answers
2k views

TeXification is too aggressive, or “How to enter a dollar sign?”

The current TeXification function is too aggressive. The current behavior is that, any text between two dollar signs in a single element will be formatted as a TeX formula. this excludes any ...
kennytm's user avatar
  • 7,495
10 votes
1 answer
1k views

Why using \mathcal command produce a square? [duplicate]

My computer is a MacBook Pro, using the 13.0 version (Ventura), and I'm using Chrome. See for example or that
Surb's user avatar
  • 55.7k
9 votes
0 answers
222 views

Persistent comment

The site went offline some time ago, and right before it did, I have received a comment reply. I could only read that comment reply after the site came back online. But now it won't go away, even ...
Asaf Karagila's user avatar
  • 394k
9 votes
2 answers
354 views

Duplicate banner breaks LaTeX

On several recent occasions, after closing a question as a possible duplicate the automatic banner breaks the $\LaTeX$ requiring manual intervening. I don't recall it was like that before, and I ...
Asaf Karagila's user avatar
  • 394k
9 votes
3 answers
1k views

Certain comment contents break LaTeX rendering for the whole page

I commented just some minutes ago on this question, and every post in math.SE returned a [Math Processing Error]. Not only for me, but for every other user. What is going on with this question. I ...
Pedro's user avatar
  • 122k
8 votes
1 answer
155 views

22 posts for review missing...

I just cleared all visible review tasks, but still the review notification cries $\hskip2in$ "~22 posts awaiting review" Does "~" mean that the service is just too slow to, or what? Or is it meant ...
draks ...'s user avatar
  • 18.5k
7 votes
1 answer
244 views

MathJax rendering issue while looking at someone's profile

I have encountered the following issue looking at my profile, see it in the photo. This also happens if I change the browser or log off from my account or even if I check from my phone, and it also ...
Zacky's user avatar
  • 27.8k
6 votes
1 answer
426 views

Tex broken for me...

I keep getting [math processing error] in bright red, everywhere on the site all the time and, while it has been amusing trying to read the raw tex code before mathjax ruins it for me, this is ...
Tom Boardman's user avatar
  • 3,515
6 votes
0 answers
175 views

Double display of formulas

Lately I've been experiencing some problems with the the display of formulas. Occasionally I get something like in this picture. I'm using Chrome on Windows 7. So far I couldn't find anything that ...
Hirshy's user avatar
  • 5,040
5 votes
2 answers
215 views

Formatting bug: long mathjax or code blocks break entire post or page

Long, broken MathJax expressions seem to break the formatting of all comments on a post, causing them to spill to far over to the right. In addition to making the comments hard to read, it can make ...
Alex Becker's user avatar
  • 60.6k
3 votes
2 answers
275 views

Title formatting of LaTeX in StackExchange hot questions list

There is the StackExchange menu at the top left on every site in our network. It opens a popup box with Hot Questions, All Sites,...
danijar's user avatar
  • 681
26 votes
1 answer
289 views

Mathjax stops rendering after clicking "An edit has been made to this post"

I have noticed in the last two weeks or so that after clicking the "An edit has been made ..." banner, the mathjax is not rendered. Example (before): (and after): Refreshing the page renders the ...
Peter Phipps's user avatar
  • 3,066
21 votes
5 answers
1k views

Please fix captcha - it hampers math sites much more than others

I intended to elaborate on the captcha problems in the original thread, but since it has been locked, I have no choice but to create a new thread. I think it is very important that the SE designers ...
Bill Dubuque's user avatar
16 votes
1 answer
401 views

Multiline MathJax on title

With the recent update, MathJax on some titles on the homepage span several lines like this: or this: This makes things a bit tricky to read. Does this happen to anyone else?
Jose Avilez's user avatar
  • 12.9k
16 votes
0 answers
285 views

No related questions are displayed (Updated)

Currently no related questions are displayed at the right hand bar. Is it just a technical problem or does it have another reason? An example has been attached. Updated: The problem has recurred again....
callculus42's user avatar
  • 30.6k
14 votes
4 answers
2k views

Firefox 4: MathML vs MathJaX

I recently started using Firefox 4. It seems that the browser understands MathML. However, the output is not as pleasing as the old MathJaX. Will this improve when Firefox 4 gets out of the Beta phase?...
Fabian's user avatar
  • 23.4k
14 votes
0 answers
203 views

Still having trouble with crashes when composing answers in Chrome

I don't know if this is true for other people, but I am still experiencing at least some of the problems described here and here, namely that Chrome crashes when I try to write answers that are too ...
Qiaochu Yuan's user avatar
11 votes
0 answers
116 views

Improve similar problem searching system

This is a problem which has happened many times when I want to ask a question on MSE. After I finish the title of my question, there'll be a Similar questions box to offer me some similar question. If ...
DreamAR's user avatar
  • 986
10 votes
0 answers
432 views

MathJax formulas hidden behind text

I have noticed that MathJax formulas are sometimes hidden behind other text and not properly displayed. I observed this only when using HTML-CSS as MathJax Renderer. (For other options the same ...
Martin Sleziak's user avatar
10 votes
2 answers
137 views

MathJax renders badly when editing from Review Queue

This has been plaguing me for some time, and I wish I'd asked about it before. I often try to "fix" math formatting for new users when I come across their posts in the Review Queue, posing hard to ...
hardmath's user avatar
  • 37k
10 votes
1 answer
339 views

Red dot on reopen queue but no items available to review

I've been experiencing a red dot on the reopen queue intermittently over the past few weeks with no items available to review. Here's a screenshot of what the behavior looks like: This screenshot was ...
KReiser's user avatar
  • 65.4k
10 votes
1 answer
108 views

Should I be getting the "Red Dot" on the "Review Queues " Icon?

This has happened twice now - I get the "red dot" on the "Review Queues" icon, but when I click on it the queues that are available to me (my rep is about 750) are all empty, though there are some ...
JonathanZ's user avatar
  • 10.7k

1
2 3 4 5 6