This is a report about a problem which occurred in the comments to Double Integrals. user6312's comment contained some latex code. I guess he forgot to type a single $ sign with the effect that everything non latex got latexfied and the other way round. (To see the problem in action take a look at the comments following this question)

The end effect (at least in firefox 4) is a comment which does not stay within the allocated column (in fact also the other comments to the questions get screwed up). It is virtually impossible to enlarge the window to such an extend that one gets access to the delete button.

Is it possible to get the comments formatted in the allocated column (that a single long line does not make all the other lines long)? An alternative would be to put the signature (and thereby the delete button) on a new line such that it will be always visible.

  • $\begingroup$ @Fabian: Now that Jeff has removed the "bug" tag, you might want to make a "feature-request" out of this. (Although it looks like a bug to me if the signature is not on a new line in such a case. However, I just tried it myself and always did get the signature on a new line. Can you post an example of the bug in the comments here? Thanks!) $\endgroup$ May 22, 2011 at 11:10
  • $\begingroup$ I don't know why the problem does not appear any more in the comment which I linked to. I seems that the user manged to resolve the problem. $\endgroup$
    – Fabian
    May 22, 2011 at 11:31
  • $\begingroup$ @Hendrik Vogt: This shows how the problem appears (I guess one can in principle make the line even longer. The first line has a latex which seems to enlarge the column width and the second line is then normal text where the signature gets hidden (at least in my screen resolution) behind other stuff. $\endgroup$
    – Fabian
    May 22, 2011 at 11:34
  • $\begingroup$ @Fabian: Thanks a lot - now it's clear how this happens. Seeing the reason, I'd say it's indeed not really a bug, but somewhat bad design. So I'd really make it a feature request to have the signature and stuff not go into the right column. Or even better: Make it so that single long lines in comments don't make all the lines of all the comments that long. $\endgroup$ May 22, 2011 at 11:41
  • $\begingroup$ @Fabian: Some of our comments were deleted. forget closing $: $x=0. I'll try and repost the bug in this comment. Here's some more filler text and yet another formula: $y=0$. Now I put enough text into the next line to push the signature far enough to the right. $\endgroup$ May 23, 2011 at 11:36
  • $\begingroup$ @Fabian: Argh, I actually didn't want you to repost a comment of that sort (mine was bad enough, or did it render OK for you?). Can you please delete your most recent comment and tell me if after that mine goes into the right column for you? $\endgroup$ May 23, 2011 at 15:27
  • $\begingroup$ @Fabian: By the way, I'm pretty sure Jeff deleted the comments to fix the layout ... $\endgroup$ May 23, 2011 at 15:35
  • $\begingroup$ @Hendrik: isn't this question exactly about this problem? There is no way for me to fix this comment now (highlight and right scroll does not work). So maybe flag it for moderator attention like Jeff recommends? $\endgroup$
    – Fabian
    May 23, 2011 at 17:11
  • $\begingroup$ Thanks for asking this question: I've encountered this a couple of times, tried in vain to edit my comment, but could not access "edit" nor "delete"! $\endgroup$
    – amWhy
    May 23, 2011 at 17:38
  • $\begingroup$ @Fabian: Ah, I see. I do it this way: $\endgroup$ May 23, 2011 at 17:42
  • $\begingroup$ select option "zoom text only" (in Firefox), and then decrease the text size. $\endgroup$ May 23, 2011 at 17:43
  • $\begingroup$ (You'll see that the "delete" sign stays large enough so you can hit it!) $\endgroup$ May 23, 2011 at 17:44
  • $\begingroup$ @Hendrik: thanks, it worked. $\endgroup$
    – Fabian
    May 23, 2011 at 18:29

3 Answers 3


In most cases, you can just click on the offending line and highlight it towards the right to scroll to the right. I don't think that it would be good to break long formulas arbitrarily.

So taking into account Theo's comment, I fully support the request for the shift of the delete sign to the next line.

  • 1
    $\begingroup$ The problem is that by Murphy's law the edit and delete hyperlinks tend to get hidden under the links in the "Related" column so that this workaround doesn't help. This happened to me several times already. $\endgroup$
    – t.b.
    May 22, 2011 at 9:24
  • $\begingroup$ @Theo Ok, you are right, I will adjust my answer accordingly. $\endgroup$
    – Phira
    May 22, 2011 at 9:31

As mentioned by Theo and Hendrik in the comments, the problem is that sometimes the edit and delete buttons get hidden behind other elements on the displayed page, making them inaccessible.

I describe a slightly convoluted, but often working way to again access those buttons in this answer.


The comment display needs to be compact, so adding another line to every single comment to address this rare user input error case -- that applies only to sites with MathJax enabled to boot -- is untenable.

Simple solution: when you see this happen, simply click 'edit' and correct the error, or flag it for moderator attention. While users can only edit comments for 5 minutes after posting, moderators can edit any comments at any time.

edit: perhaps a better solution would be to detect and close any unclosed $$ pairs in comments?

  • $\begingroup$ I am not at all surprised that there will not be a global fix for a tex-specific problem, but I don't agree with your "advice". As you can see in the comment to my answer, it's not true that it is always simple to fix and it is really unhelpful to answer this question with "Well, just don't make errors.". $\endgroup$
    – Phira
    May 23, 2011 at 5:50
  • 2
    $\begingroup$ actually, my advice is "when you see an error, correct it", as stated above. $\endgroup$ May 23, 2011 at 5:53
  • 10
    $\begingroup$ Actually, what user9325 meant that it is not always easy to follow your advice since sometimes the "edit" link is well hidden within other links in the right column. $\endgroup$ May 23, 2011 at 8:03
  • 3
    $\begingroup$ You're only addressing the alternative here. Fabian's first suggestion was "Is it possible to get the comments formatted in the allocated column (so that a single long line does not make all the other lines long)?" This would indeed be helpful. As for the alternative, why not just make it so that the signature is pushed to the next line only if otherwise it would end in (or right of) the right column? (I think noone wants you to add another line to every single comment.) $\endgroup$ May 23, 2011 at 11:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .