4
$\begingroup$

EDIT: the below is due to me recently installing the STIX fonts, which came with an installation of texlive-full. This question is now concerned with how to avoid rendering the aesthetically inferior fonts.

I have noticed that capital Sigma, both as $\Sigma$, and as the summation symbol as in $\sum_{i}^{n}$, appears to have been subject to a recent graphics change. The $\sum$ symbol now looks markedly different from what it used to look like a few days ago. Here is a comparison between MathJax and native LaTeX: $$\sum_{i=0}^{\infty} i^2$$$\quad\quad\quad\quad\quad\quad\quad\quad\quad\quad\quad\quad\quad\quad\quad\quad\;\:\:$enter image description here

Just in case that this is actually a fault with my system, here's a screenshot of what $$\sum_{i=0}^{\infty} i^2$$ currently looks to me on M.SE:

enter image description here

What's going on here? Why this change? I know that it is inconsequential to the mathematics concerned, but I think that it is aesthetically inferior.

$\endgroup$
  • $\begingroup$ In my system (Vista, Firefox 26.0), the $\LaTeX$ and the MathJax summations are the same. But I do feel like I've seen that "bolded" looking sum on one of my devices... $\endgroup$ – apnorton Dec 30 '13 at 4:34
  • 1
    $\begingroup$ My screenshot of your post (with your screenshot, yay recursion). Looks like it's your system. Did you get STIX fonts recently, by any change? By the way, changes to the version of MathJax used are usually (always?) announced here on Meta, and there was no such announcement recently. $\endgroup$ – Post No Bulls Dec 30 '13 at 4:52
  • $\begingroup$ @PostNoBills I recently installed texlive-full. $\endgroup$ – Newb Dec 30 '13 at 4:54
  • $\begingroup$ I don't use TeX Live, but a Google search shows they were working on adding STIX. This may be the cause of your change. See this comment from MathJax team. $\endgroup$ – Post No Bulls Dec 30 '13 at 4:59
  • $\begingroup$ What should I do to use MathJax without the STIX fonts? I could just uninstall STIX, but I don't want to risk that in case of dependencies. $\endgroup$ – Newb Dec 30 '13 at 5:01
  • $\begingroup$ @Newb The summation looks good for me: i.stack.imgur.com/YRdFX.png $\endgroup$ – user93957 Dec 30 '13 at 10:08
  • 1
    $\begingroup$ Using Arch Linux, I don't have STIX fonts with my texlive package and everything works. I installed them as an additional package at some point, and removed them shortly after. Nothing bad happen. If you are not afraid of reinstalling texlive, I suggest you to perhaps try and see if you can remove the fonts cleanly. $\endgroup$ – Asaf Karagila Dec 31 '13 at 10:30
8
$\begingroup$

As suggested by Post No Bills, it appears you have installed the STIX fonts, and MathJax will use local STIX fonts before its web-based fonts (since that is faster). There are two ways to prevent this.

  1. Install the MathJax TeX fonts locally (these will be used in preference to local STIX fonts). You will need to download them individually, as we don't have them packaged for distribution directly.

  2. Open the browser console window and type MathJax.Menu.showFontMenu(true) in the command line. This should make the MathJax contextual menu include a new "Font Preferences" menu in the "Math Settings" submenu. Select "TeX (web)" from this menu to force the use of the MathJax web fonts. Note that the page will reload when you change this setting.

    This setting is sticky, so should be in force for a year (on the site where you set it). The font menu will not reappear after the page is reloaded (you will have to issue the command again if you want to change the setting again).

Either should resolve the issue for you.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .